Nextcloud error installation


#1

Hello guys, I installed nextcloud with the nextcloud_install script. After typing YES, my admin name and a password, three errors occur

Bildschirmfoto%20vom%202018-11-29%2020-56-05

These errors prevent me from setting up Nextcloud any further. Can anyone help me fix it?

My Turris Omnia was freshly set up with all new updates.


#3

i have same problem.
i could not find any solution on forums


#4

utf8mb4 enables Emoji (UTF8 4-byte) support with MySQL. Not sure why that is needed in the first place.

Maybe installing the package perlbase-utf8 helps. Or else from the cli something in this direction

sudo -u nobody www-data php occ config:system:set mysql.utf8mb4 --type boolean --value="false"

or

sudo -u nobody php-cli occ config:system:set mysql.utf8mb4 --type boolean --value="false"


#5

it seems perlbase-utf8 was missing.
after install of that package, nextcloud_install did not show errors anymore.

BTW. my system was cleanly installed from medkit 3.11 and was upgraded to 3.11.1