New router registration is missing

I got a new Omnia and the registration link https://www.turris.cz/cs/data/register-router/?email=xxxxxxx returns NOT FOUND. Perhaps it moved somewhere when you redid the web site.

I believe the right link is now https://project.turris.cz/cs/data/register-router?email=xxxxxxx My guess is that when the website was redone the corresponding urls shown in the router UI weren’t changed.

/cc @vaclav (I don’t know whom to ping).

Anyone looking into this one? I found several other places in the foris code where www.turris.cz is hardcoded, it’s likely that those links are broken too.

Hi,
I want to apologise for the inconvenience created by changes on the website. Everything should work correctly now.

Thank you. Progress is being made but we are still not perfect, I think. The link is https://project.turris.cz/cs/data/register-router/?email=bill%40xxxxxx&registration_code=36355xxxxxxxxx. and returns “Stránka nenalezena”. Who knew I would get to learn Czech.

I think the best bet is for you to review your web server logs for 404 errors. I tried a few things and eventually got a page where I could enter the registration code. We are now waiting for a day to go by to see if you get data.

Bill

@Vaclav, @merriam is correct. currently when you register for data collection you are redirected to the page

https://project.turris.cz/cs/data/register-router/?email=foo%40example.com&registration_code=some_long_code

it should really be

https://project.turris.cz/cs/data/register-router?email=foo%40example.com&registration_code=some_long_code

Very small but critical difference: the correct url drops the slash character between “router” and the question mark in the URL. Please fix.