Netmetr sync not working


Since a few months, I could not use my sync code on Netmetr website as it was reported as invalid.

During last update, I have deleted the sync code from the code file to have a new one generated. On the website, my code is recognized and it shows my old measurements. But new measurements still cannot be seen.

On Forris, I see latest measurements as expected.


thank you for your feedback. Could you provide us with config file located at /etc/config/netmetr and a full debug output generated by running netmetr --debug? Have tried to delete line containing sync_code more than once?

Here is my conf file:

And here is the debug output:

No, I have only tried to delete the line containing the sync_code once.

I’ve already written it here: Turris OS 3.9.5 now in RC!

Yes, I had reported it along 3.4 release as well but it seems my comment was lost among other topics related to that release.

1 Like

@mprudek any news about this bug? Are the provided output and conf helpful?

thank you for the conf file and debug output. If I understand it clearly - your new sync code is showing some measurements but it doeen’t show the newest measurements measured on Turris? Anyway, send me please a full sync code and full uuid in PM. We will check it in DB.

I have manually applied this commit and it fixed it.

OK, yes but the new code does nothing, but deleting the sync code before each measurement. So I’m a bit confused how the manually applied commit could be more helpful then manually deleted sync code. Anyway, thank you for you feedback!

Indeed. The commit is not explicit either why such a behavior is needed.