Netdata not displaying correctly with dark theme


#1

I didn’t use netdata for a while and there were some updates in the meantime and now when I go to netdata stats it’s not displaying correctly the meters. Screenshot attached:

Users of netdata: Could you please check if it’s only on my box?


#2

Hello,

I don’t have any issues with Netdata. Based on your post, I tried Netdata version 1.11.1 (it’s known bug for me, that Netdata currently shows different version), which is currently in Turris OS 3.11.2 and Turris OS 4.0 (Alpha2 - hbs). In RC, there’s a newer version of Netdata, you may try to switch to RC, if you’re not using it.

Here is a screenshot from Turris MOX:


This screenshot is created on Ubuntu 18.10, Google Chrome browser and it works also on Mozilla Firefox. Usually, I’m trying it also on Windows 10, there is Mozilla Firefox. No issues so far.

Unfortunately, in your post, there are not many details, which could help me to reproduce your issue.
May I ask you for additional information?

  • Which browser are you using?
    (Sometimes it also helps to know on which operating system you tried it)
  • Does it happen also on other devices as well?
  • Which version of Turris OS do you have?
  • Is something in Browser console?

Would you please SSH to your router and copy&paste this command?

/etc/init.d/netdata restart

Once you do that, please try to visit the Netdata dashboard again and press ctrl + f5 to see, if the issue persists.


#3

HOST: Debian 9.8 Stretch - Mozilla Firefox 60.5.1

I tried restarting netdata - no success. I tried reinstalling with deleting the config - no success.
I tried restarting the router - no success. I also tried Firefox with no addons - no success.

Ok I switched to RC = > upgrading now. And will post result.
And anyway I wanted to test alpha3 of TOS4.x soon so moving forward is a must.

EDIT: Nope. Switched to RC (3.11.3) and still the same.

EDIT2: The only browser console error is this:
Script error:
TypeError: context.unsafeWindow is undefined
Stack trace:
userScript/<@user-script:AdsBypasser/AdsBypasser:525:1
userScript@user-script:AdsBypasser/AdsBypasser:520:2
scopeWrapper@user-script:AdsBypasser/AdsBypasser:7771:9
@user-script:AdsBypasser/AdsBypasser:493:17
AdsBypasser:7773:23

Will try also with my phone… With my phone displaying is fine. I don’t know what might be wrong.