Nefunkční Turris 1 po předposledním updatu

Dobrý den,
pár dní po posledním updatu (11.12.2016) jsem restartoval turris (vypnutím ze zásuvky), už do funkčního stavu nenaběhl. Link měl, ale nic víc jsem z něj nevytáhl.
Mám klasické připojení s DHCP clientem a veřejkou přímo na WAN rozhraní (UPC).
Po resetu routeru dojde k instalaci aktualizací, ta se povede. V dalším kroku instalace aktualizací už ne. Internet ~funguje (routing + maškaráda TCP/UDP ok, ale vytočit ze stanice za turrisem PPTP do internetu nejde).

Od tohoto okamžiku je webové rozhraní nedostupné. Dá se ale připojit přes SSH s nastaveným heslem, spustit updater.sh, který toho hodně postahuje a skončí s exit 0. Webové rozhraní stále nefunguje. Následuje cyklus reboot, s časovým odstupem kontrola webového rozhraní (nefunguje), updater.sh (něco dělá, žádné pending offline updates, exit 0), kontrola webového rozhraní (nefunguje). Po asi patnácti opakováních jsem si všiml, že výstup se příliš nemění. Mění se doba, po kterou na začátku čeká (např. + TIME=109), ale seznam balíčků, které aktualizuje, zůstává stejný.

Kdykoli se pokusím nastartovat lighttpd, dopadne to takhle. Nezáleží na tom, jestli je to hned při prvním přihlášení, nebo až po všech opakování updater.sh .
root@turris:~# /etc/init.d/lighttpd start
/usr/sbin/lighttpd: can’t load library ‘libpcre.so.0’

Pokud provedu opkg upgrade, zprovozním tím Foris do funkčního stavu. Začne nějak fungovat i Luci, ale nenastavím např. portforwarding. PPTP nefunguje stále, ale můžu si ve Forisu změnit např. SSID. Nefunguje ale uCollect, a chodí mi tak zprávy o výpadcích. Vzhledem k tomu, že opkg upgrade zjevně nedoporučujete, považuji další popis po opkg upgrade za irelevantní.

Tento postup jsem opakoval během posledních týdnů čtyřikrát s různými obměnami, bez úspěchu. Přiložil bych i /var/log/updater-resume.log, ale je docela velký, kdyžtak ho někam uploadnu .

Možná jsem někde přehlédl nějaké zásadní sdělení, jak mám po resetu postupovat, v tom případě se velice omlouvám. Nicméně obvyklá cesta přes webové rozhraní je nemožná, protože nefunguje, dokud neprovedu opkg upgrade. Teprve pak můžu dokončit průvodce ve Forisu (se skip wizard, aktualizace už nefungují).

Nenarazil jste někde na další podobné vlákno? Hledal jsem, ale ať nezakládám duplicity.

Ve vašem postu nevidím zminku o obnově systému?

Na tuhle možnost jsem úplně zapomněl, díky. Budu mít o svátcích co dělat :slight_smile:

Raději s tou obnovou ještě počkejte… https://forum.test.turris.cz/t/instalace-konci-chybou-segmentation-fault-opet/2539/7

To je teda radost.
Zatím ho nahradím Mikrotikem, a snad to vyřeším dřív, než ho budu muset vrátit.

Potvrzuji stejné chování na Turrisu 1.0, už sem psal na technickou podporu a nemám odpoveď. Doufám že poslední aktualizace tohle chování srovnají.

Jinak - ve wizzardu sem šel do kroku 5, pak sem dal přeškočit průvodce a pokračoval sem konfigurací v LuCi. Od té doby Turris drží a ani moc nejsou výpadky uCollectu (za poslední den asi 1h).

Nicméně se chystám na obnovu systému z SD karty.

Připojuji se ke výčtu uživatelů, kteří registrují popsané problémy na T1. Po aktualizacích a restartu nefunkční administrace přes http (Foris i Luci). Prostřednictvím SSH po opkg upgrade router uveden alespoň do polofunkčního stavu, obnovu přes SD jsem zatím nezkoušel. Teď se mi aktualizovalo jádro na 3.10.18 a je požadován restart, který se bojím provést v obavě, že se znovu dostanu do původního stavu. Takže v podstatě stejné peripetie jako egyptský ranhojič, který založil tento thread.

nahrani posledni verze z SD karty a prechod na ubifs u me castecne zafungovaly. Router funguje ale prace s diskem je nefunkcni - po zapisu/precteni cca 500MB se mi router automaticky sam zrestartuje. Dela to jak u USB fleshky tak SD karty ve slotu. To se mi predtim nedelo…

Tak obavy oprávněné. Kombinace chyby v posledním jádru a nemožnosti vypnout aktualizace je vražedná. Po automatickém restartu se smyčka problému vrací na začátek. Opět bez možnosti administrace přes http nefunkční wifi. Pro tuto chvíli je má trpělivost vyčerpána.

Jinak funguje vám s těmahle kombinacema uCollect? Já mám už výpadek 144h (20% maxima).

Já už jsem na 58%, odpověd od správců Turrisu byla jen automatická, že jsou přetíženi prací. Určitě nemám chu’t se v tom denně vrtat a testovat různá nastavení, když před updatem na 3.10.xxx všechno běželo 2 roky naprosto v pohodě. V nejhorším jim Turrise odevzdám za porušení podmínek (100% výpadek) a pořídím Mikrotika.

Tak bohužel jsem na tom stejně po dnešku. Začalo to výpadky LAN, tak jsem dal tovární nastavení v domnění že vše půjde. Prvotní konfigurace mi skončí na stejné chybě a dál už se nedostanu. Po přeskočení a pokusu o update je po restartu komplet LUCI i Foris nedostupné. Nepomohlo ani obnovení image z SD karty, momentálně mám doma polofunkční router. Ví někdo jak z toho ven?

po včerejšu uplně stejně (předtím jsem parkrát dal opkg update/upgrade a pak po včerejšu update přez fortis s restartem)!
naštěstí to routuje aspoň na lanku a dělá vše kromě wifi a web nastavení(ale přez ssh se dá)
(obnova systemu (v flash paměti mam uplbě ten puvodni), a pak uvodni nastaveni a update na nejnovější)

takže teď jedu co se dá na kabel a zbytek jede na přivěšený huj a hej (huawei) modem/swich nastaveny do brige…

Mě dorazil tento email:

Dobrý den,

omlouvám se za delší dobu odezvy. Chtěla bych se zeptat zda se problém již
vyřešil, případně bych doporučila obnovu systému a zavaděče z SD karty.
Podrobný návod naleznete zde:
https://www.turris.cz/doc/cs/troubleshooting/sdcard_recovery
Přeji pokojné svátky,

Nora
Turris servis

Tak to zejtra zkusím.

Na Twitteru ještě odepsali:
“Pokud je router ve stavu, kdy jej nedokážete zprovoznit, pošlete nám jej na servis.”

Díky za nabídku, zejtra dopoledne vyzkouším tu obnovu z SD karty, a v případě, že to nevyjde, tak využiji vaší nabídky. Mejlacz

Tak já sem opět ve funkčním stavu.
Zafungoval u mě tento postup:

  1. Tovarni nastavení (reset, připojit napájení, po cca 15s uvolnit tlačítko reset)
  2. Proklikat tutorial co nejdále jde (v 6. Kroku zahlásí že se všechny aktualizace nepodařilo nainstalovat)
  3. Přes web restart, spustit updater.sh podle stavu /top/updater-status/status sem sledoval co se děje (příp. Tail -D log2). Po delší době si updater řekl o restart (soft) tak sem udělal reboot.
  4. Reboot, doinstalování nějaké aktualizace, Lighttpd stale nejede
  5. Opkg update;opkg upgrade; - zfunkcneno Lighttpd
  6. Updater.sh doinstalovat opět aktualizace, reboot
  7. Po zadání IP routeru je funkční foris (až na to že mi chvíli ukazoval vtipne logo Omnie na Turrisu 1.0), dokonfiguroval sem zbytek ve forisu a zdá se být vše OK.

Edit:
Beru zpět, opkg konci cokoliv na segfault což se řeší v jiném vláknu

Nahradil jsem Turris Mikrotikem, zapojil WAN portem do vnitřní sítě, a nastavil podle doporučení uživatele Filip:

Jinak - ve wizzardu sem šel do kroku 5, pak sem dal přeškočit průvodce a pokračoval sem konfigurací v LuCi. Od té doby Turris drží a ani moc nejsou výpadky uCollectu (za poslední den asi 1h).

Turris běží, emaily o výpadku už nechodí, ale je nepoužitelný, protože čekám, kdy si sám stáhne nové updaty, nebo se prostě restartuje, a opět nerozběhne. Doufám, že to podpora vyřeší, takhle je to jaksi k ničemu pro všechny strany.
Můj Turris teď v síti nedělá nic, je jen online, aby se koza (uCollect) nažrala.

Já jsem Turris vyřadi - momentálně běží jen jako switch za routerem… Pokud je zařízení nefunkční je to pro mně bezpečnostní riziko. Nemohu nastavit nic. Přidělení IP adres, Firewall, porty, nic a to si nemohu dovolit. Nikdo po mně nemůže chtít plnění smlouvy když je zařízení s kterým mám tu smlouvu plnit neprovozuschopné. Počkám do ledna jestli se problém podaří vyřešit OTA a pokud ne zašlu ho na servis.