Need help with Installation

I tried to install my new router. I used on ethernet cable from my computer to the router LAN0 and another ethernet cable from WAN to modem. I tried to run the First Run & Foris Interface. It made it up to Step 7. Updated for a long time, then quit and now I can’t do anything.

It says: took too long to respond. I tried last night, again today. Same thing.

I have model: RTROM01. I am using a 2009 MacBook Pro to install. I have a brand new Mac but this has no ethernet cable.

Is there a simple solution?

I tested my cables. Both are working. I don’t know that much about routers so I need help in layperson terms.

Thank you for help.

If you ever get really stuck you can always do a factory reset, bookmark this page. Or better yet keep a printed copy around for future reference.

Thanks. I did try a reset at one point.

I tried another computer and still cannot get it running. Can someone show me where to get support or tell me why my computers are not responding to the link? Is there a setup wizard I can download?

You should reset your modem first before starting the first time Foris setup process?

Hi, you can get some support here or on

There is not any setup wizard app.

What is Steps 7? Updating router?