Nedostupnost Wifi


#1

Dobrý den,

mám Turrins Omnia a na jednom notebooku s Windows 10 mi “vypadává” wifi. Provozuji pouze 2.4GHz, ručně na kanálu č.5. Notebook se připojí, funguje a z ničeho nic konec. GW nepingnu. Odpojím se od wifi, připojím, projdou 4 pingy a zase konec. Tak mohu donekonečna. Pomůže pouze vypnutí a zapnutí wifi, nebo reboot routeru.

Notebook je Dell s kartou Intel Centrino Advanced-N 6250. Na jiných wifi sítích se mi to nestává (TP-Link, Cisco, ASUS, Lenovo Android s HotSpotem, Extricom).

V logu Turrisu jsem nic neobjevil. Neměl byste pro mě někdo radu, na co se zaměřit?

Díky, Milo


#2

Jeden notebook s Win10 nám tohle začal dělat – ale chovalo se to divně – zařízení v “disabled” stavu, apod. Vyhrabal jsem starou Wi-Fi kartu (taky Intel), v notebooku vyměnil a problémy zmizely. Samozřejmě může jít o úplně jiný případ.


#3

Po delší době používání jsem zjistil, že nefunguje dobře ani připojení iPhone 7 a Lenovo tabletu. DNS resolving se chová podivně ať už je DNSsec na routeru zapnutý nebo ne.
Nevím, jestli to je chybným HW routeru, ale když se po hard rebootu začne chovat korektně, tak asi ne.


#4

Zdravím,
můžete, prosím, upřesnit, co si mohu představit, že nefunguje připojení na Vámi zmiňovaných zařízení?
Odpojování nebo se jedná o problém uvedený ve Vašem prvním příspěvku nebo nemůžete načíst některé konkrétní stránky?

Zmiňujete DNS resolving, že se chová podivně. Na tohle může mít DNSSEC vliv, ale jen v případě, že ISP nepodporuje DNSSEC, ale většinou pomůže vypnout/zapnout forwarding.
Pokud máte zapnutý forwarding, tak se dotazy ptají DNS serveru Vašeho poskytovatele.
Pokud je vypnutý, tak se ptají serverů roztroušených po Internetu.
Více k této problematice je v naší dokumentaci.

K tomu notebooku s WiFi kartou Intel 6250, pokud v logu routeru nic není, což se mi zdá zvláštní, tak bych zkusil vypnout power saving.


#5

Osobně bych se nejprve snažil zjistit, zda jde o problém v DNS. Nejjednodušeji přes ping na nějakou spolehlivou číselnou adresu (8.8.8.8, 9.9.9.9).


#6

K Dell notebooku z prvního příspěvku… jen upřesním, že pokud se od SSID odpojím a zpět připojím, projde 4 až 7 pingů. A přibližně: první a druhý má odezvu 1ms, třetí 3ms, pátý 120ms, sedmý 670ms a konec.

iPhone jsem moc nedebugoval. Výpadky se projevily chybou “DNS LOOKUP FAILED” (nebo tak nějak) v Safari. Několik refreshů stránky zabralo.

U Lenovo tabletu bych odhadl chybu na packet loss. Webovky se nenačítaly celé, chyběly styly, obrázky. Různá API nativních aplikaci (GitHub klient, Twitter…) timeoutovaly. Pak jsem zkusil pingy na GW a občas nějaký nedošel.

DNS jsem zkoušel v různých kombinací. Vypnutý i zapnutý forwarding. Staticky nastavené DNS servery CESNETu nebo Googlu. Nakonec i svůj soukromý DNS resolver, abych viděl do logů, ale paket buď přišel, nebo ne.

Pokud jsem notebook připojit ethernet kabelem, vše běželo krásně. Bez packet lossu. Po rebootu routeru běžela krásně i Wifi. Ale třeba jen den, dva, ale třeba také ani ne hodinu nebo 15 minut.

Osobně si myslím, že je problém na wifi vrstvě a chyby v DNS resolvingu už jsou jen důsledkem packet lossu.

Dnes už bohužel moje trpělivost došla, Turris skončil v šuplíku a starý router pracuje bez chyby.


#7

Jo, zní to tak, že DNS problémy jsou až druhotné.


#8

Taky mám jeden podobný problémek s WiFi. Ale jen na jednom NB (Toshiba Satellite A50). Po startu systému musím vždy nejprve wifi restartovat, protože jinak jsou pingy podobné jako se popisuje výše - 10,15 ms, pak 670, 2 800ms, pak zase chvíli 25,30,15ms.

Když na NB wifi restartnu, tak vše třeba celý den funguje jak má (někdy ne a je potřeba další restart v průběhu dne). Zvláštní je, že mi to kdysi nedělalo, projevilo až po nějakém updatu Gentoo a dodnes jsem nebyl schopen zjistit, proč se tak děje a proč restart pomůže. Prostě když wifi po startu systému nerestartuji, tak mi internet hapruje. A nepomohly žádné berličky aka automatický restart wifi po cca 2 minutách od bootu. Vždy musím wifi restartovat ručně až po spuštění KDE.

Taky je to jediné zařízení, kde se mi to projevuje. Další dva NB a čtyři telefony jedou přes wifi naprosto v pohodě. Mám trochu podezření, že za tím stojí nějaká nekompatibilita té wifi karty (i když to je intel). Na těch dalších dvou NB mám sice taky Intel, ale jiné řady.