Nedaří se migrace na TOS 5

Ahoj,
včera mi přišel Turris 1.0 z druhé ruky, tak jsem hned provedl obnovení s SD karty, obnovení továrního nastavení, nainstaloval všechny aktualizace a zahájil migraci na BTRFS. Následně jsem přes updater nechal nainstalovat migrační balíček na TOS 5 a nechal to běžet přes noc.

Turris běží a routuje, ale nedá se na něj dostat - 500 Internal Server Error

Jak postupovat dál? Jsem připojený konzolovým kabelem.

Patrik

Zadejte v CLI příkaz “mount” který prozradí, že:

  1. / (tedy rootFS) je uložen na microSD kartě (/dev/mmcblk0p2)
  2. / (tedy rootFS) má filesystem typu btrfs

Tyto indicie prozradí, že router běží na BTRFS

1 Like

Bohužel:
root@turris:/# mount
/bin/ash: mount: not found

A stejně tak ls, cat, opkg :-/

Ale router zatím routeruje. Dá se z toho vytáhnou nějaký log aby se dalo zjistit co se pokazilo? Je to prakticky defaultní konfigurace…

Tak po rebootu už nenajede:

U-Boot 2015.04-04654-gbcfb33e-dirty (Jun 26 2015 - 12:50:49)

CPU0: P2020E, Version: 2.1, (0x80ea0021)
Core: e500, Version: 5.1, (0x80211051)
Clock Configuration:
CPU0:1200 MHz, CPU1:1200 MHz,
CCB:600 MHz,
DDR:400 MHz (800 MT/s data rate) (Asynchronous), LBC:37.500 MHz
L1: D-cache 32 KiB enabled
I-cache 32 KiB enabled
wdt status 00000005 reset
Watchdog enabled
Board: TURRIS CPLD: V4.1 PCBA: V4.0
Error, wrong i2c adapter 2 max 2 possible
in: 56
out: 0
io_config: 255
rom_loc: nor upper bank
SD/MMC : 4-bit Mode
eSPI : Enabled
I2C: Error, wrong i2c adapter 2 max 2 possible
ready
SPI: ready
DRAM: Error, wrong i2c adapter 2 max 2 possible
Detected UDIMM 9905428-181.A00LF
WARNING: Calling __hwconfig without a buffer and before environment is ready
WARNING: Calling __hwconfig without a buffer and before environment is ready
2 GiB (DDR3, 64-bit, CL=6, ECC off)
Flash: 16 MiB
L2: 512 KiB enabled
NAND: 256 MiB
MMC: FSL_SDHC: 0
PCIe1: Root Complex of mini PCIe SLOT, no link, regs @ 0xffe0a000
PCIe1: Bus 00 - 00
PCIe2: Root Complex of PCIe SLOT, x1 gen1, regs @ 0xffe09000
02:00.0 - 168c:0030 - Network controller
PCIe2: Bus 01 - 02
PCIe3: Root Complex of PCIe SLOT, no link, regs @ 0xffe08000
PCIe3: Bus 03 - 03
Error, wrong i2c adapter 2 max 2 possible
In: serial
Out: serial
Err: serial
Net: Phy 5 not found
PHY reset timed out
eTSEC1
Error: eTSEC1 address not set.
, eTSEC2
Error: eTSEC2 address not set.
, eTSEC3 [PRIME]
Error: eTSEC3 address not set.

Hit any key to stop autoboot: 0
BOOT NAND
reading zImage
3319984 bytes read in 193 ms (16.4 MiB/s)
wdt status 00000003
reading fdt
12945 bytes read in 13 ms (971.7 KiB/s)
WARNING: adjusting available memory to 30000000

Booting kernel from Legacy Image at 02100000 …

Image Name: Linux-4.4.199-f90a52a6230ecb072f
Created: 2020-11-13 0:35:31 UTC
Image Type: PowerPC Linux Kernel Image (gzip compressed)
Data Size: 3319920 Bytes = 3.2 MiB
Load Address: 00000000
Entry Point: 00000000
Verifying Checksum … OK

Flattened Device Tree blob at 02000000

Booting using the fdt blob at 0x2000000
Uncompressing Kernel Image … OK
Loading Device Tree to 03ff9000, end 03fff290 … OK
WARNING: could not find compatible node fsl-usb2-dr
[ 0.000000] Using P2020 RDB machine description
[ 0.000000] Memory CAM mapping: 256/256 Mb, residual: 1536Mb
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Initializing cgroup subsys cpuacct
[ 0.000000] Linux version 4.4.199-f90a52a6230ecb072f657fce5aebd444-1 (beast@b uild) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r47055) ) #1 SMP Fri No v 13 01:35:22 CET 2020
[ 0.000000] CPU maps initialized for 1 thread per core
[ 0.000000] bootconsole [udbg0] enabled
setup_arch: initmem
mpc85xx_rdb_setup_arch()
[ 0.000000] mpc85xx_qe_init: Could not find Quicc Engine node
[ 0.000000] MPC85xx RDB board from Freescale Semiconductor
arch: exit
[ 0.000000] barrier-nospec: using isync; sync as speculation barrier
[ 0.000000] Zone ranges:
[ 0.000000] DMA [mem 0x0000000000000000-0x000000001fffffff]
[ 0.000000] Normal empty
[ 0.000000] HighMem [mem 0x0000000020000000-0x000000007fffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x0000000000000000-0x000000007fffffff]
[ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x000000007fffffff]
[ 0.000000] MMU: Allocated 1088 bytes of context maps for 255 contexts
[ 0.000000] PERCPU: Embedded 10 pages/cpu @dedc2000 s9420 r8192 d23348 u40960
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pag es: 523136
[ 0.000000] Kernel command line: root=/dev/mmcblk0p2 rootwait rw rootfstype=b trfs rootflags=subvol=@,commit=5 console=ttyS0,115200
[ 0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[ 0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[ 0.000000] Sorting __ex_table…
[ 0.000000] Memory: 2005324K/2097152K available (5048K kernel code, 180K rwda ta, 1100K rodata, 200K init, 244K bss, 91828K reserved, 0K cma-reserved, 1572856 K highmem)
[ 0.000000] Kernel virtual memory layout:
[ 0.000000] * 0xfffbf000…0xfffff000 : fixmap
[ 0.000000] * 0xffc00000…0xffe00000 : highmem PTEs
[ 0.000000] * 0xffbfd000…0xffc00000 : early ioremap
[ 0.000000] * 0xe1000000…0xffbfd000 : vmalloc & ioremap
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
[ 0.000000] Hierarchical RCU implementation.
[ 0.000000] NR_IRQS:512 nr_irqs:512 16
[ 0.000000] mpic: Setting up MPIC " OpenPIC " version 1.2 at ffe40000, max 2 CPUs
[ 0.000000] mpic: ISU size: 256, shift: 8, mask: ff
[ 0.000000] mpic: Initializing for 256 sources
[ 0.000000] mpc85xx_rdb_pic_init: Could not find qe-ic node
[ 0.000008] clocksource: timebase: mask: 0xffffffffffffffff max_cycles: 0x114 c1bade8, max_idle_ns: 440795203839 ns
[ 0.010276] clocksource: timebase mult[d555555] shift[24] registered
[ 0.016657] pid_max: default: 32768 minimum: 301
[ 0.021305] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.027843] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.035253] Initializing cgroup subsys io
[ 0.039190] Initializing cgroup subsys memory
[ 0.043542] Initializing cgroup subsys devices
[ 0.047964] Initializing cgroup subsys freezer
[ 0.052397] Initializing cgroup subsys net_cls
[ 0.056829] Initializing cgroup subsys pids
[ 0.061147] mpic: requesting IPIs…
[ 0.065665] Brought up 2 CPUs
[ 0.070677] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, ma x_idle_ns: 1911260446275000 ns
[ 0.080354] futex hash table entries: 512 (order: 2, 16384 bytes)
[ 0.086529] xor: measuring software checksum speed
[ 0.101288] 8regs : 1472.000 MB/sec
[ 0.115426] 8regs_prefetch: 1312.000 MB/sec
[ 0.129910] 32regs : 1472.000 MB/sec
[ 0.144045] 32regs_prefetch: 1356.000 MB/sec
[ 0.148578] xor: using function: 32regs (1472.000 MB/sec)
[ 0.154297] NET: Registered protocol family 16
[ 0.163701] cpuidle: using governor ladder

[ 0.173956] Found FSL PCI host bridge at 0x00000000ffe08000. Firmware bus num ber: 0->0
[ 0.181806] PCI host bridge /pcie@ffe08000 (primary) ranges:
[ 0.187453] MEM 0x00000000c0000000…0x00000000dfffffff -> 0x00000000c0000000
[ 0.194666] IO 0x00000000ffc20000…0x00000000ffc2ffff -> 0x0000000000000000
[ 0.201804] /pcie@ffe08000: PCICSRBAR @ 0xfff00000
[ 0.206574] setup_pci_atmu: end of DRAM 80000000
[ 0.211441] Found FSL PCI host bridge at 0x00000000ffe09000. Firmware bus num ber: 0->1
[ 0.219282] PCI host bridge /pcie@ffe09000 ranges:
[ 0.224150] MEM 0x00000000a0000000…0x00000000bfffffff -> 0x00000000a0000000
[ 0.231364] IO 0x00000000ffc10000…0x00000000ffc1ffff -> 0x0000000000000000
[ 0.238500] /pcie@ffe09000: PCICSRBAR @ 0xfff00000
[ 0.243272] setup_pci_atmu: end of DRAM 80000000
[ 0.248129] Found FSL PCI host bridge at 0x00000000ffe0a000. Firmware bus num ber: 0->0
[ 0.255971] PCI host bridge /pcie@ffe0a000 ranges:
[ 0.260839] MEM 0x0000000080000000…0x000000009fffffff -> 0x0000000080000000
[ 0.268053] IO 0x00000000ffc00000…0x00000000ffc0ffff -> 0x0000000000000000
[ 0.275189] /pcie@ffe0a000: PCICSRBAR @ 0xfff00000
[ 0.279961] setup_pci_atmu: end of DRAM 80000000
[ 0.293317] PCI: Probing PCI hardware
[ 0.297051] fsl-pci ffe08000.pcie: PCI host bridge to bus 0000:00
[ 0.303071] pci_bus 0000:00: root bus resource [io 0x0000-0xffff]
[ 0.309238] pci_bus 0000:00: root bus resource [mem 0xc0000000-0xdfffffff]
[ 0.316107] pci_bus 0000:00: root bus resource [bus 00-ff]
[ 0.321879] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), rec onfiguring
[ 0.329898] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[ 0.335241] fsl-pci ffe09000.pcie: PCI host bridge to bus 0001:02
[ 0.341262] pci_bus 0001:02: root bus resource [io 0x20000-0x2ffff] (bus add ress [0x0000-0xffff])
[ 0.350211] pci_bus 0001:02: root bus resource [mem 0xa0000000-0xbfffffff]
[ 0.357078] pci_bus 0001:02: root bus resource [bus 02-ff]
[ 0.362797] pci 0001:02:00.0: Primary bus is hard wired to 0
[ 0.368381] pci 0001:02:00.0: bridge configuration invalid ([bus 01-01]), rec onfiguring
[ 0.378401] pci 0001:02:00.0: PCI bridge to [bus 03-ff]
[ 0.383759] fsl-pci ffe0a000.pcie: PCI host bridge to bus 0002:04
[ 0.389784] pci_bus 0002:04: root bus resource [io 0x40000-0x4ffff] (bus add ress [0x0000-0xffff])
[ 0.398728] pci_bus 0002:04: root bus resource [mem 0x80000000-0x9fffffff]
[ 0.405596] pci_bus 0002:04: root bus resource [bus 04-ff]
[ 0.411326] pci 0002:04:00.0: bridge configuration invalid ([bus 00-00]), rec onfiguring
[ 0.419343] pci 0002:04:00.0: PCI bridge to [bus 05-ff]
[ 0.424579] PCI: Cannot allocate resource region 0 of PCI bridge 1, will rema p
[ 0.431730] PCI: Cannot allocate resource region 0 of device 0000:00:00.0, wi ll remap
[ 0.439550] PCI: Cannot allocate resource region 0 of device 0001:02:00.0, wi ll remap
[ 0.447373] PCI: Cannot allocate resource region 0 of device 0002:04:00.0, wi ll remap
[ 0.455228] pci 0000:00:00.0: BAR 0: no space for [mem size 0x00100000]
[ 0.461803] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x00100000]
[ 0.468757] pci 0000:00:00.0: PCI bridge to [bus 01]
[ 0.473712] pci 0000:00:00.0: bridge window [mem 0xc0000000-0xdfffffff]
[ 0.480493] pci_bus 0000:00: Some PCI device resources are unassigned, try bo oting with pci=realloc
[ 0.489563] pci 0001:02:00.0: BAR 0: no space for [mem size 0x00100000]
[ 0.496140] pci 0001:02:00.0: BAR 0: failed to assign [mem size 0x00100000]
[ 0.503098] pci 0001:03:00.0: BAR 6: assigned [mem 0xa0020000-0xa002ffff pref ]
[ 0.510315] pci 0001:02:00.0: PCI bridge to [bus 03]
[ 0.515266] pci 0001:02:00.0: bridge window [io 0x20000-0x2ffff]
[ 0.521525] pci 0001:02:00.0: bridge window [mem 0xa0000000-0xbfffffff]
[ 0.528305] pci_bus 0001:02: Some PCI device resources are unassigned, try bo oting with pci=realloc
[ 0.537384] pci 0002:04:00.0: BAR 0: no space for [mem size 0x00100000]
[ 0.543954] pci 0002:04:00.0: BAR 0: failed to assign [mem size 0x00100000]
[ 0.550907] pci 0002:04:00.0: PCI bridge to [bus 05]
[ 0.555863] pci 0002:04:00.0: bridge window [io 0x40000-0x4ffff]
[ 0.562122] pci 0002:04:00.0: bridge window [mem 0x80000000-0x9fffffff]
[ 0.568903] pci_bus 0002:04: Some PCI device resources are unassigned, try bo oting with pci=realloc
[ 0.578228] mpic-msgr ffe41400.message: Found 0 message registers
[ 0.584245] mpic-msgr ffe41400.message: Of-device full name /soc@ffe00000/mes sage@41400
[ 0.592249] mpic-msgr ffe41400.message: Failed to find message register block alias
[ 0.624746] raid6: int32x1 gen() 171 MB/s
[ 0.646133] raid6: int32x1 xor() 220 MB/s
[ 0.667447] raid6: int32x2 gen() 300 MB/s
[ 0.688816] raid6: int32x2 xor() 261 MB/s
[ 0.710118] raid6: int32x4 gen() 398 MB/s
[ 0.731422] raid6: int32x4 xor() 283 MB/s
[ 0.752783] raid6: int32x8 gen() 378 MB/s
[ 0.774117] raid6: int32x8 xor() 253 MB/s
[ 0.778303] raid6: using algorithm int32x4 gen() 398 MB/s
[ 0.783691] raid6: … xor() 283 MB/s, rmw enabled
[ 0.788560] raid6: using intx1 recovery algorithm
[ 0.794429] clocksource: Switched to clocksource timebase
[ 0.800682] NET: Registered protocol family 2
[ 0.805321] TCP established hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.812325] TCP bind hash table entries: 4096 (order: 3, 32768 bytes)
[ 0.818766] TCP: Hash tables configured (established 4096 bind 4096)
[ 0.825137] UDP hash table entries: 256 (order: 1, 8192 bytes)
[ 0.830915] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
[ 0.837274] NET: Registered protocol family 1
[ 0.847804] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.853728] jffs2: version 2.2 (NAND) (SUMMARY) (ZLIB) (LZO) (LZMA) (RTIME) ( RUBIN) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.
[ 0.866417] bounce: pool size: 64 pages
[ 0.870230] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 2 52)
[ 0.877568] io scheduler noop registered
[ 0.881475] io scheduler deadline registered (default)
[ 0.886899] pcieport 0001:02:00.0: enabling device (0106 -> 0107)
[ 0.893061] pcieport 0002:04:00.0: enabling device (0106 -> 0107)
[ 0.899400] pcieport 0000:00:00.0: Signaling PME through PCIe PME interrupt
[ 0.906316] pcieport 0001:02:00.0: Signaling PME through PCIe PME interrupt
[ 0.913240] pci 0001:03:00.0: Signaling PME through PCIe PME interrupt
[ 0.919794] pcieport 0002:04:00.0: Signaling PME through PCIe PME interrupt
[ 0.952739] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.961245] console [ttyS0] disabled
[ 0.964779] serial8250.0: ttyS0 at MMIO 0xffe04500 (irq = 42, base_baud = 375 00000) is a 16550A
[ 0.973454] console [ttyS0] enabled
[ 0.973454] console [ttyS0] enabled
[ 0.980394] bootconsole [udbg0] disabled
[ 0.980394] bootconsole [udbg0] disabled
[ 0.988630] serial8250.0: ttyS1 at MMIO 0xffe04600 (irq = 42, base_baud = 375 00000) is a 16550A
[ 0.997911] console [ttyS0] disabled
[ 1.001527] console [ttyS0] enabled
[ 1.005437] ffe04600.serial: ttyS1 at MMIO 0xffe04600 (irq = 42, base_baud = 37500000) is a 16550
[ 1.021399] brd: module loaded
[ 1.025177] ef000000.nor: Found 1 x16 devices at 0x0 in 16-bit bank. Manufact urer ID 0x000001 Chip ID 0x002101
[ 1.035201] Amd/Fujitsu Extended Query Table at 0x0040
[ 1.040369] Amd/Fujitsu Extended Query version 1.3.
[ 1.045427] number of CFI chips: 1
[ 1.049064] 6 ofpart partitions found on MTD device ef000000.nor
[ 1.055115] Creating 6 MTD partitions on “ef000000.nor”:
[ 1.060437] 0x000000000000-0x000000020000 : “NOR (RO) DTB Image”
[ 1.067063] 0x000000020000-0x0000001c0000 : “NOR (RO) Linux Kernel Image”
[ 1.074428] 0x0000001c0000-0x000000340000 : “NOR (RO) JFFS2 Root File System”
[ 1.082153] 0x000000340000-0x000000e40000 : “NOR (RO) NAND FW backup”
[ 1.089157] 0x000000e40000-0x000000f00000 : “NOR (RW) Cert backup”
[ 1.095901] 0x000000f00000-0x000001000000 : “NOR (RO) U-Boot Image”
[ 1.103250] nand: device found, Manufacturer ID: 0x2c, Chip ID: 0xda
[ 1.109621] nand: Micron MT29F2G08ABAEAWP
[ 1.113634] nand: 256 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB siz e: 64
[ 1.122542] Bad block table found at page 131008, version 0x02
[ 1.129149] Bad block table found at page 130944, version 0x02
[ 1.135333] nand_read_bbt: bad block at 0x000005a00000
[ 1.140717] 4 ofpart partitions found on MTD device ff800000.flash
[ 1.146909] Creating 4 MTD partitions on “ff800000.flash”:
[ 1.152402] 0x000000000000-0x000000200000 : “NAND (RW) DTB Image”
[ 1.159077] 0x000000200000-0x000000700000 : “NAND (RW) Linux Kernel Image”
[ 1.166497] 0x000000700000-0x000010000000 : "NAND (RW) JFFS2 Root File System "
[ 1.174480] 0x000000000000-0x000010000000 : “rootfs-ubifs”
[ 1.180730] eLBC NAND device at 0xff800000, bank 1
[ 1.185966] fsl_espi ffe07000.spi: cs=0, init_csmode=0x100008
[ 1.191733] fsl_espi ffe07000.spi: cs=1, init_csmode=0x100008
[ 1.197493] fsl_espi ffe07000.spi: cs=2, init_csmode=0x100008
[ 1.203248] fsl_espi ffe07000.spi: cs=3, init_csmode=0x100008
[ 1.210073] fsl_espi ffe07000.spi: at 0xe11c0000 (irq = 59)
[ 1.216099] libphy: Fixed MDIO Bus: probed
[ 1.220390] libphy: Freescale PowerQUICC MII Bus: probed
[ 1.228249] switch0: Atheros AR8337 rev. 2 switch registered on mdio@ffe24520
[ 1.280213] fsl-gianfar ffe24000.ethernet: enabled errata workarounds, flags: 0x4
[ 1.298147] fsl-gianfar ffe24000.ethernet eth0: mac: 00:00:00:00:00:00
[ 1.304687] fsl-gianfar ffe24000.ethernet eth0: Running with NAPI enabled
[ 1.311484] fsl-gianfar ffe24000.ethernet eth0: RX BD ring size for Q[0]: 256
[ 1.318627] fsl-gianfar ffe24000.ethernet eth0: TX BD ring size for Q[0]: 256
[ 1.326057] fsl-gianfar ffe25000.ethernet: enabled errata workarounds, flags: 0x4
[ 1.343942] fsl-gianfar ffe25000.ethernet eth1: mac: 00:00:00:00:00:00
[ 1.350483] fsl-gianfar ffe25000.ethernet eth1: Running with NAPI enabled
[ 1.357279] fsl-gianfar ffe25000.ethernet eth1: RX BD ring size for Q[0]: 256
[ 1.364422] fsl-gianfar ffe25000.ethernet eth1: TX BD ring size for Q[0]: 256
[ 1.371640] fsl-gianfar ffe26000.ethernet: enabled errata workarounds, flags: 0x4
[ 1.389502] fsl-gianfar ffe26000.ethernet eth2: mac: 00:00:00:00:00:00
[ 1.396048] fsl-gianfar ffe26000.ethernet eth2: Running with NAPI enabled
[ 1.402845] fsl-gianfar ffe26000.ethernet eth2: RX BD ring size for Q[0]: 256
[ 1.409988] fsl-gianfar ffe26000.ethernet eth2: TX BD ring size for Q[0]: 256
[ 1.417216] ucc_geth_driver: QE UCC Gigabit Ethernet Controller
[ 1.423332] i2c /dev entries driver
[ 1.426956] mpc-i2c ffe03000.i2c: timeout 1000000 us
[ 1.433943] rtc-ds1307 0-006f: SET TIME!
[ 1.440164] rtc-ds1307 0-006f: rtc core: registered mcp7940x as rtc0
[ 1.446539] rtc-ds1307 0-006f: 64 bytes nvram
[ 1.451076] mpc-i2c ffe03100.i2c: timeout 1000000 us
[ 1.456316] booke_wdt: powerpc book-e watchdog driver loaded
[ 1.462168] sdhci: Secure Digital Host Controller Interface driver
[ 1.468358] sdhci: Copyright© Pierre Ossman
[ 1.472719] sdhci-pltfm: SDHCI platform and OF driver helper
[ 1.478557] sdhci-esdhc ffe2e000.sdhc: No vmmc regulator found
[ 1.484401] sdhci-esdhc ffe2e000.sdhc: No vqmmc regulator found
[ 1.513042] mmc0: SDHCI controller on ffe2e000.sdhc [ffe2e000.sdhc] using DMA
[ 1.520902] NET: Registered protocol family 10
[ 1.525962] NET: Registered protocol family 17
[ 1.530465] bridge: automatic filtering via arp/ip/ip6tables has been depreca ted. Update your scripts to load br_netfilter if you need this.
[ 1.543123] Bridge firewalling registered
[ 1.547152] 8021q: 802.1Q VLAN Support v1.8
[ 1.552170] BTRFS: using crc32c-generic for crc32c
[ 1.558314] Btrfs loaded, integrity-checker=on
[ 1.564246] rtc-ds1307 0-006f: setting system clock to 2001-01-01 00:00:00 UT C (978307200)
[ 1.573108] Waiting for root device /dev/mmcblk0p2…
[ 1.587527] mmc0: new high speed SDHC card at address 0001
[ 1.593377] mmcblk0: mmc0:0001 00000 7.61 GiB
[ 1.598581] mmcblk0: p1 p2
[ 1.679702] BTRFS: device fsid b5c19281-dbeb-4cd1-8f37-4d00e14fdb1f devid 1 t ransid 29 /dev/root
[ 1.689673] BTRFS info (device mmcblk0p2): disk space caching is enabled
[ 1.696390] BTRFS: has skinny extents
[ 1.715617] BTRFS: detected SSD devices, enabling SSD mode
[ 1.785071] VFS: Mounted root (btrfs filesystem) on device 0:13.
[ 1.791320] Freeing unused kernel memory: 200K
[ 1.809257] Kernel panic - not syncing: No working init found. Try passing i nit= option to kernel. See Linux Documentation/init.txt for guidance.
[ 1.822401] CPU: 1 PID: 1 Comm: swapper/0 Not tainted 4.4.199-f90a52a6230ecb0 72f657fce5aebd444-1 #1
[ 1.831447] Call Trace:
[ 1.833896] [da843ec0] [c04ed1f8] dump_stack+0x84/0xb0 (unreliable)
[ 1.840169] [da843ed0] [c04e8d94] panic+0xe0/0x21c
[ 1.844963] [da843f30] [c0002cf8] kernel_init+0x108/0x120
[ 1.850367] [da843f40] [c000e2c4] ret_from_kernel_thread+0x5c/0x64
[ 1.856553] —[ end Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.

Po obnovení a opětovné aktualizaci už jedu z BTRFS. To co včera selhalo je pravděpodobně migrace na Turris OS 5. To je tak když něco necháte běžet přes noc, a ještě si dáte aktualizovat svůj počítač…

Zahájil jsem tedy znovu migraci na TOS 5, web rozhraní už teď hází “500 Internal Server Error” tak schválně jestli se tentokrát probere. Uvidíme asi zase až ráno.

Tak bohužel, na druhý pokus, stejný výsledek. Název tématu i úvodní příspěvek jsem upravil.

Ahoj pro instalaci TOS5 na Turris 1.x doporucim postupovat podle uživatele crown z příspěvku Jak manualne nainstalovat TOS 5 na modrak případně použij obnovu z sdkarty dle mého návodu ze stejného tématu.

Přechod z tos3 na tos5 pomocí webového rozhraní jsem několikrát zkoušel i na úplně defaultni konfiguraci (po aktualizaci tos3 na poslední verzi) a vždy skončila s errorem 500 a nemožností ovládat i přes CLI.

1 Like

Jo, to už jsem na svém prvním modrákovi taky dělal. Jen jsem doufal, že by ta migrace alespoň s defaultní konfigurací mohla proběhnout v pohodě. no nestalo se.

Opravdu jsi postupoval podle https://docs.turris.cz/geek/tos3-migration/#optional-migration

Danger

On Turris 1.x before first reboot, after migration is completed, you have to run following command over SSH: ROOT_DIR=/ /etc/updater/hook_postupdate/10_kernel-install. Failing to not do so can result in to not-booting router.

P.S. Ostatně pokud máš router v defaultní konfiguraci, tak nevidím důvod nejít stylem nahrání medkitu TOS5… Díky němu běžím uz 3/4 roku

Postupoval. Bohužel se na modrák po pár minutách od potvrzení instalace 3to5 balíku už nedá dostat jinak než přes seriovou konzoli.

Update is finished once you receive notification that migration was finished. Message in question starts with with sentence: Migraton from Turris OS 3.x was completed..

Tuhle notifikaci si nemám kde přečíst.

On Turris 1.x before first reboot, after migration is completed, you have to run following command over SSH: ROOT_DIR=/ /etc/updater/hook_postupdate/10_kernel-install. Failing to not do so can result in to not-booting router.

Nepoznám kdy je migrace dokončena, protože nic nefunguje, ani to SSH.

Prostě se to celý rozbije.

Už jsem to taky nahrál přes medkit, a všechno funguje, ale očekával jsem, že ta migrace přes 3to5 bude s defaultní konfigurací bez problému.

Ostatně hodně aktualizacím vadilo i to, že jsem byl připojený přes wifi. Jakmile probíhal update, tak to celé spadlo. Nesmíš taky zapomínat, že T 1.x je “starý” kus hardwáru" a Turris tým dělá vše pro to, aby byl pořád updatován i přes to, že routery byly distribuovány za 1 kč. Ostatně T 1.x není zatím ani v TOS5 oficiálně podporován, ale sám již od počátku věřím, že pepe a cynerd s vmyslivec dělají maximum aby se daly používat. Který výrobce by to dělal u 10 let starého routeru ?! :slight_smile:

Nejlepší bude instalace přes medkit skrz btrfs imort :slight_smile:

1 Like

No, já byl celou dobu připojený kabelem.

Však jasně, jen jsem prostě čekal, že když je už možnost migrovat přes klikátko, že to bude fungovat. Toť vše. Doufám, že podpora modráků, minimálně na úrovní bezpečnostních aktualizací ještě nějakou dobu vydrží.

Díky za informace. Mrkneme na to, co se tam děje. Mezitím v dalším releasu pro verzi Turris OS 3.x bude opětovně migrace zakázána pro modré Turrisy.

3 Likes

Za mne také doporučuji na modrákovi update na 5. verzi odložit, i když jsem obnovil čistý systém, tak se mi nepodařilo rozchodit 5G WIFI na Radio1 - mám dokoupený upgrade balíček a funguje to jen pod 3.x verzí. Dokonce když už jsem měl rozchozenu verzi 5.1.4 jen s Radio0 anténou a proběhl update na 5.1.5 tak mi foris napsal že WIFI nemám vůbec.Testoval jsem to jen v neděli, když nebyl nikdo doma, takže jsem se rychle vrátil na 3.x. Mám k dispozici schnapps zálohu, kdyby bylo potřeba, ale na 3.x problém nemám.

Na mém prvním modrákovi mám původní kartu pro 5Ghz a přídavnou pro 2,4Ghz a žádné problém nepozoruji. Tento druhý modrák už taky dostal přídavnou 2,4Ghz kartu a funguje v podstatě v té samé konfiguraci. Jediný s čím mě tento druhý modrák potrápil je to, že se včera sám od sebere restartoval a dneska ráno nejelo připojení přes USB LTE modem - restart interfacu to vyřešil. Mohl to být i problém samotného modemu.

Zatím jsem Vámi zminovaný problém zde na fóru nenarazil a myslím si, že na podpoře nám to zatím nikdo nehlásil. Mohlo by to souviset s konfigurací Wi-Fi sítě, případně jí vyresetovat a nastavit znovu, ale uvítali bychom zaslání syslogu, konfiguračního souboru /etc/config/wireless a výstup lspci, případně rovnou diagnostiky na technickou podporu a podíváme se na to.

Resetování jsem zkoušel, konfiguraci současného stavu 3.11.21 vám na technickou podporu můžu poslat

Jen mě tak zajímá, bavíme se o konfiguraci přes Foris, re-Foris nebo Luci?

Edit: Aha, jsem slepej, Foris. Mám za to, že tohle se mi ve Forisu taky stalo, nevím v jaké verzi, už je to nějaký čas. Nevěnoval jsem tomu pozornost, protože vše co jde nastavit Luci, nastavuju tam. Určitě bych se kvůli tomu na verzi 3.x nevracel. :slight_smile:

Ono toho bylo víc, nefungovala mi ani VPN, ale tu WIFI jsem se pokoušel zprovoznit i v Luci a tam se mi taky nedařilo, Zkoušel jsem i alternativní ovladače pro Qualcomm Atheros QCA986x/988x , ale nějak se nezadařilo. Jedinou výhodu co jsem viděl ve verzi 5.x byla možnost spravování Schnappsotů v grafické podobě ale když nefungují ostatní důležitější věci jako wifi nebo vpn, tak to pro mne nebylo přínosné. Možná kdybych neměl router jako hlavní, tak bych testoval víc, ale takto jsem rád když vše běží jako od začátku a nevím o něm. (jsem spokojený uživatel s 3.11.21.)

Měl jsem podobný problém, Turris 1.0, upgrade btrfs, pak TOS 3x to 5x a dostal jsem se do podobného stavu jako uvedeno výše. Podotýkám, připojení přes kabel, WiFi nepoužívám.
Tzn. UI nejelo a přes SSH jsem dostával pouze root@turris:/bin# ls -ash: ls: not found
Turris aspoň routoval jak měl.
Nicméně se dalo spustit toto:
root@turris:/bin# pkgupdate
e[34mINFOe[0m:Target Turris OS: 5.1.6
e[34mINFOe[0m:Queue install of libjson-c/base/0.12.1-3.1
e[34mINFOe[0m:Queue install of libblobmsg-json/base/2020-05-25-66195aee-1
e[34mINFOe[0m:Queue install of ubusd/base/2019-12-27-041c9d1c-1
e[34mINFOe[0m:Queue install of libubus/base/2019-12-27-041c9d1c-1
e[34mINFOe[0m:Queue install of ubus/base/2019-12-27-041c9d1c-1

UI i SSL už bylo použitelné s výjimkou reforisu. Tam jsem měl známou modrou hlášku, ale to opět spravilo přidání
reforis
reforis-diagnostics-plugin
reforis-netboot-plugin
reforis-netmetr-plugin
reforis-remote-devices-plugin
reforis-snapshots-plugin
Od té doby, cca 2 dny jsem na verzi 5.1.6 a Turris drží, bez restartu a i DHCP přiděluje jak má.
Snad to někomu pomůže…