My 2GB LTE model arrived

And I am happy, but the LTE card is a bit too fat :stuck_out_tongue:

Fat LTE problem: https://www.flickr.com/photos/doommeer/30134726020/in/album-72157675325916246/
it gets stuck on the SIM slot, that is just “semi” good.

more turris pictures https://www.flickr.com/photos/doommeer/sets/72157675325916246

3 Likes

Hi DooMMasteR,

Today I tried to install LTE module and I’m experiencing exactly by the same issue.

Turris Team,

Could you please let us know how you are gona fix this? This is simply design flaw! When installing LTE module shielding on bottom side of module interfere with SIM slot. Please help.

David

1 Like

Should I see the LTE modem listed with lspci command ?
root@turris:/sbin# lspci
00:01.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:02.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:03.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
01:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
02:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter

I think it is linked via USB
There should be a /dev/ttyUSB0 and 1
You can install the usb-utils or tools and use lsusb to take a look at the device

The space problem will not be solved… I added 2 washers to the mounting pole and fixed it by preventing useless stress on the card and mainboard, the connectors are quite tolerant and it works fine so far.

1 Like

Yes spacers are like temp solution, but cooling pad will be affected by this definitely as card will be sitting less flatter this means contact of cooling element with case cover will be not on whole surface.

1 Like

Hmm…interesting, considering they provide Mainboard and also that LTE module…
As I have ordered the very same combo, I will also have to figure something out… :unamused:

1 Like

Hi, can you help me with instalation /dev/ttyUSB2 ?
Automatic updates i can not run, because
I have not installed modem.
Modem I can not install because I have not installed /dev/ttyUSB2 …

thx.

/dev/ttyUSBn should be there once the LTE modem is installed, I do not think that additional software should be needed.

https://www.turris.cz/doc/en/howto/lte_modem_install