MWAN3 error in log

Hello.

I have problem with mwan3:

root@TurrisOmnia:~# mwan3 restart
/usr/sbin/mwan3: local: line 3: not in a function
/sbin/hotplug-call: local: line 3: not in a function
/sbin/hotplug-call: local: line 25: not in a function
Device "'br-lan'" does not exist.
/sbin/hotplug-call: local: line 3: not in a function
/sbin/hotplug-call: local: line 25: not in a function
Device "'br-lan'" does not exist.

These scripts from MWAN3 do not use “ash” from the busybox package?

Can anyone have an idea how to solve the problem?

Could you post your network config. It can be found here. (remember to change 192.168.1.1 if you have another ipadres for your Omnia.

http://192.168.1.1/cgi-bin/luci/admin/network/mwan/advanced/networkconfig

“br-lan” is the default LAN (eth0). If you go to interfaces, there click on LAN. There you will be able to see “br-lan”.

TAB: General setup:
In this TAB, you have a static IP-adres, subnetmask

TAB: Advanced Settings:
In this TAB, i have only bring up on boot, Use builtin IPv6-management i have NOT checked, as i do not use Ipv6.

TAB: Physical settings:
Bridge interfaces: check
Enable STP: uncheck
Interface: eth0 and 2 of my wifi’s.

I do not use VLAN. eth1 & eth2 are my WAN2 & WAN3 and another wifi is my WAN.

Firewall settings: you have to be in LAN.(green)

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd58:36af:49d2::/48'

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option _orig_ifname 'eth0 eth2 turris_0 turris_1'
	option _orig_bridge 'true'
	option ifname 'eth0 eth2 turris_0 turris_1'

config interface 'wan'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr '192.168.0.2'
	option netmask '255.255.255.0'
	option gateway '192.168.0.1'
	list dns '8.8.8.8'
	list dns '9.9.9.9'
	option metric '10'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6'

config interface 'wan2'
	option ifname 'usb0'
	option _orig_ifname 'usb0'
	option _orig_bridge 'false'
	option proto 'dhcp'
	option metric '20'

I do not think that this information is needed.
Someone from the Polish OpenWRT forum wrote that the problem is in TurrisOS.

You use something different as a shell than ash from busybox in this turris. The problem in the syntax of the script is.

Have you configured MWAN configuration correctly? As you have also ANOTHER WAN like me. You have called it WAN6.

I have WAN, WAN2, WAN3.

Or that is the default wan6 (do pardon me, as i have removed that one long ago.). Take a look at my network config.

I have mine running just fine. (wifi dongle WAN), eth1 (wan2) eth2 (wan3). So it has to do with your configuration maybe? What version of mwan do you have?

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix <REMOVED>

config interface ‘lan’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
list dns ‘8.8.8.8’
list dns ‘8.8.4.4’
option _orig_ifname ‘eth0 eth2 wlan0 wlan1’
option _orig_bridge ‘true’
option delegate ‘0’
option ifname ‘eth0’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0 1 2 3 5’
option vid ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘4 6’
option vid ‘2’

config interface ‘guest_turris’
option enabled ‘1’
option type ‘bridge’
option ifname ‘guest_turris_0 guest_turris_1 guest_turris_2’
option proto ‘static’
option ipaddr ‘10.111.222.1’
option netmask ‘255.255.255.0’
option delegate ‘0’

config interface ‘wan2’
option proto ‘static’
option ifname ‘eth1’
option delegate ‘0’
option ipaddr ‘192.168.1.179’
option netmask ‘255.255.255.0’
option metric ‘20’
option gateway ‘192.168.1.180’
option dns ‘8.8.8.8 8.8.4.4’

config interface ‘wan3’
option proto ‘static’
option ifname ‘eth2’
option delegate ‘0’
option ipaddr ‘192.168.1.178’
option netmask ‘255.255.255.0’
option metric ‘30’
option gateway ‘192.168.1.182’
option dns ‘8.8.8.8 8.8.4.4’

config interface ‘wan’
option proto ‘dhcp’
option metric ‘10’
option dns ‘8.8.8.8 8.8.4.4’

mwan3 version of mine.

root@K-Router:~# opkg info mwan3
Package: mwan3
Version: 2.0-2

root@TurrisOmnia:~# opkg info mwan3
Package: mwan3
Version: 2.0-2
Depends: libc, ip, ipset, iptables, iptables-mod-conntrack-extra, iptables-mod-ipopt
Status: install user installed
Section: net
Architecture: all
Maintainer: Jeroen Louwes <jeroen.louwes@gmail.com>
Size: 7500
Filename: mwan3_2.0-2_all.ipk
Conffiles:
 /etc/config/mwan3 2aa3b512e13bb868d702050660676df1f0acae13e1379be44a8b5e83185aaee3
Source: feeds/turrispackages/net/mwan3
Description: Hotplug script which makes configuration of multiple WAN interfaces simple
 and manageable. With loadbalancing/failover support for up to 250 wan
 interfaces, connection tracking and an easy to manage traffic ruleset.
Installed-Time: 1519552792

Take a good look at my network config.

Change some of the things like my config. For example with your WAN change to

config interface ‘wan’
option ifname ‘eth1’
option proto ‘static’
option delegate ‘0’
option ipaddr ‘192.168.0.2’
option netmask ‘255.255.255.0’
option gateway ‘192.168.0.1’
option dns ‘8.8.8.8 9.9.9.9’
option metric ‘10’

config interface ‘wan2’
option proto ‘dhcp’
option metric ‘20’
option dns ‘8.8.8.8 9.9.9.9’

Could you post printscreen of your “interfaces”-page & post printscreen of your firewall settings TAB.