mSATA users, did the 5.3.0 update break anything?

For me nothing broke.
If you have backup, try cleaning the SSD and then format it using reforis

Apparently you’re not the only one: Turris OS 5.3 is released! - #12 by rmsthebest

I don’t have this issue, but under Storage in Reforis, I see the following message: "

Your router is waiting for restart to proceed with migrating your data to the newly selected drive. Please restart your router as soon as possible but bear in mind that the next reboot will take longer as all data need to be migrated.

The drive is mounted fine under /srv and I can see the data. I never requested any migration.

I had exactly the same issue after updating to 5.3.0 and rebooting the device. Unmounting in LuCI didn’t work, reformatting the mSATA drive in reForis didn’t change anything, several reboots of the Omnia didn’t change this.

I solved this by removing the mount point in the “Mount Points” section in LuCI (go to the “Mount Points” page, scroll to “Mount Points”, delete the mount point (e.g., /dev/sda/)). I then rebooted the device, and could access /srv again. Interestingly, formatting the mSATA drive in reForis didn’t work (the web UI said it was formatted, but all the files were still there).

1 Like

that’s why I suggested to clean (reset) the SSD first. But the solution may be the above anyway…

fdisk -l # show drives
hdparm -I /dev/sda #show drive Infos and lock for "frozen" state!!! shoud be not frozen/locked
hdparm --security-set-pass NULL /dev/sdb # set the "NULL" password to UNLOCK the Controller
hdparm --security-erase NULL /dev/sda # run secure erase!

Ok, looks like you should not have your srv mentioned anymore on /etc/config/storage file, if you don’t have have RAID in use. If you comment out srv part from yout /etc/config/storage file … then you can have your /srv enabled on /etc/config/fstab. And this will auto mount /srv correctly at start.

Feels like new version of NAS “extension” just can’t not be used any more if you don’t use RAID? And removing RAID support (mdadm) does not help. It still offers RAID options on reForis, and expects anything mentioned on storage file to be RAID?


Yep, same for me: a notification e-mail about an update needing restart, automatic restart during night, in the morning, LXC does not work, connected to Turris to investigate… and the whole drive is gone. (With the suspicious notice about data migration to the newly attached drive at the next reboot displayed in Reforis.)

Removing the entry from /etc/config/storage and rebooting helped.

Thanks a huge lot, alump! I really thought for a moment the data was gone completely!

1 Like

Same thing happened to me. All the home services that I have run in LXC containers. This broke everything that I bought and use my Omnia for. I still haven’t managed to fix it. Also, I don’t have Mount Points anymore in LuCI?!

That’s it. I’m disabling automatic updates. I don’t have time to troubleshoot broken updates. The QA on these is horrible.

Nothing broke for me. Storage USB drive works as well as system mSATA drive (my eMMC has worn out, thus I boot from mSATA). LXC had no problem. But it’s probably a bit different configuration, as I don’t have Storage on the mSATA.

For anyone coming to this thread and looking to fix this issue, I’ve marked the issue solved by user alump’s post because several people tried it and it worked for them.

In my case I contacted the Turris support team and they helped me troubleshoot right away. I had backups of /srv and was OK with wiping the mSATA drive and starting over, and the following commands fixed the problem for me.

Do NOT do this if you want to keep the data from your mSATA drive, it’s destructive and reformats after rebooting. Follow the accepted solution above instead.

uci show storage.srv # Get your drive UUID
uci delete storage.srv.uuid='<replace_with_your_actual_UUID>' # Delete existing drive from config, triggering a reformat, data is lost!
uci commit storage # Save changes
reboot # Now you can see and manage the drive in reForis

Hope this helps and while I know bugs in updates are frustrating, the Turris team were very quick to assist me and I’m confident they will fix this soon. You can help by contacting support and supplying diagnostics info just like you would for any open-source project.

1 Like


Thanks for your instructions. After commenting out in /etc/config/storage, how do I enable it in /etc/config/fstab? Is this supposed to happen automatically?

Update went smooth, I have an entry in /etc/config/storage for my internal mSATA like this:

config srv 'srv'
        option uuid 'XXX'

Nothing broke, automount on boot works, no other mounts, no RAID

Lines in /etc/config/fstab should look something like:

config mount
	option target '/srv'
	option uuid 'YOUR-UUID'
	option enabled '1'

Replace the YOUR_UUID with UUID of your srv partition. As alternative you can go to Luci and use it’s UI flow to define your partition to be used as /srv and to be auto mounted.

Thank you. I managed to mount it with this. The issue was also that I no longer had the Mount Points page in LuCI, so I couldn’t do anything through that UI. After I did this, the Mount Points page showed up again.

Another weird issue is that now after it’s mounted as /srv on the SSD there is a directory called @ and all my previous files and containers and everything are in that directory. I’m not sure why that is. Previously they were all directly in /srv, so I assume until I move them I won’t see the LXC containers in LuCI or be able to use them. It’s all very weird.

Could @s mean that there is some mapping issue to the right snapshot (~@subvolumes) on your partition? Sorry long time since I have played with those. This is just a wild guess. – i haven’t used snapshots on /srv partition, only on / (root).

I have same issue from relasing 5.3.0 in HBK. Since i don’t really need to use Storage plugin in reForis i just “disable” disk here and everything works fine. Now only reForis plugins what need Storage plugin will not correctly work ( i managed to install and run NextCloud anyway through command line ).
I’m using mount points in LUCI.

I ended up using your solution to at least make a backup of the files on the SSD with rsync to an external drive, then I removed the changes to /etc/config/fstab and /etc/config/storage, rebooted then used the solution Turris support gave @tombrossman . I had to format and set the SSD as external storage again through Forris. Then I restored all the files back with rsync and now my LXC containers are there and work.

I can confirm that this solution worked for me as well. Thanks!


Is there any chance you have been able to resolve the issue with @?
I change the /etc/config/fstab as suggested and mSATA mounted just fine but still have this annoying problem with @ folder that is in the way.

Thank you!

Add subvol=@ to the mount options.