Mpd not working on turris after update to version 3.3

Hi,

before update to version 3.3 mpd was working. Now it does not start. Config file mpd.conf still the same. Manual start with --no-daemon option output is:
root@turris:~# mpd --no-daemon -v
config_file: loading file /etc/mpd.conf
Dec 08 19:20 : path: SetFSCharset: fs charset is: UTF-8
Dec 08 19:20 : db: Tag list mismatch, discarding database file
Dec 08 19:20 : output: No ‘AudioOutput’ defined in config file
Dec 08 19:20 : output: Attempt to detect audio output device
Dec 08 19:20 : output: Attempting to detect a alsa audio device
Segmentation fault

Any ideas, what went wrong or what to check?

Thanks

If you have mpd-full it now has support for pulseaudio, not sure if this is what causes crash (it works fine for me).

Anyway you can specify audio output in config file (just uncomment the alsa or pulse section depending on what you want to use) and that would avoid the autodetection which seems to be causing problems.

Solved. Thank you Nijel. Uncommenting Alsa block solved the issue. Now it plays music through USB soundcard again.