MOX Super Wired - setup

I just received a new MOX Super Wired. I’m trying to set it up, but I’m not lucky.

I have encountered these issues:

  1. I expected that the default configuration would have DHCP client enabled on port 0 (MOX A) Unfortunately, it wasn’t.
  2. On 8 LAN ports I did not receive automatic configuration from DHCP server.
  3. I found in the documentation that the default IP is 192.168.1.1. This IP did not respond to either port.
  4. Since I had no way to proceed with the configuration, I tried to reset and install from the Cloud. That didn’t help.
  5. I connected to the serial console using a hacker pack. I see that Router has started, but it doesn’t work with the keyboard imput. So I tried to connect from another PC and the same situation. The keyboard does not work in the serial console.

How to proceed to make this nice piece of HW operational?

Boot:
U-Boot 2018.11 (Dec 16 2018 - 12:50:19 +0000), Build: jenkins-turris-os-packages-kittens-mox-90

DRAM: 1 GiB
Enabling Armada 3720 wComphy-0: SGMII1 3.125 Gbps
Comphy-1: PEX0 5 Gbps
Comphy-2: USB3_HOST0 5 Gbps
MMC: sdhci@d8000: 0
Loading Environment from SPI Flash… SF: Detected w25q64dw with page size 256 Bytes, erase size 4 KiB, total 8 MiB
OK
Model: CZ.NIC Turris Mox Board
Net: eth0: neta@30000
Turris Mox:
Board version: 22
RAM size: 1024 MiB
Serial Number:
ECDSA Public Key: 03008e9d4d2bb9477d197ca4bfca430bbdb3922a7d9433d45868da2249738ad165b46a8e60562d285e15f4982c6cae7aa3bbcd2f04bf5a25aff2541d50cfabe52f39f5
SD/eMMC version: SD
Module Topology:
1: Peridot Switch Module (8-port)

Hit any key to stop autoboot: 0
gpio: pin GPIO221 (gpio 57) value is 0
gpio: pin GPIO220 (gpio 56) value is 1
SF: Detected w25q64dw with page size 256 Bytes, erase size 4 KiB, total 8 MiB
device 0 offset 0x7f0000, size 0x10000
SF: 65536 bytes @ 0x7f0000 Read: OK
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1…
Found U-Boot script /boot.scr
403 bytes read in 66 ms (5.9 KiB/s)

## Executing script at 04d00000

9959432 bytes read in 474 ms (20 MiB/s)
19292 bytes read in 61 ms (308.6 KiB/s)

## Flattened Device Tree blob at 04f00000

Booting using the fdt blob at 0x4f00000
Loading Device Tree to 000000003bf14000, end 000000003bf1bb5b … OK

Starting kernel …

[ 0.000000] Booting Linux on physical CPU 0x0
[ 0.000000] Linux version 4.14.107 (beast@slave10) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 42c5a2c5bb)) #0 SMP Thu Mar 28 00:09:04 2019
[ 0.000000] Boot CPU: AArch64 Processor [410fd034]
[ 0.000000] Machine model: CZ.NIC Turris Mox Board
[ 0.000000] earlycon: ar3700_uart0 at MMIO 0x00000000d0012000 (options ‘’)
[ 0.000000] bootconsole [ar3700_uart0] enabled
[ 0.000000] psci: probing for conduit method from DT.
[ 0.000000] psci: PSCIv1.1 detected in firmware.
[ 0.000000] psci: Using standard PSCI v0.2 function IDs
[ 0.000000] psci: MIGRATE_INFO_TYPE not supported.
[ 0.000000] psci: SMC Calling Convention v1.1
[ 0.000000] random: get_random_bytes called from start_kernel+0x80/0x458 with crng_init=0
[ 0.000000] percpu: Embedded 17 pages/cpu @ffffffc03ffbe000 s28824 r8192 d32616 u69632
[ 0.000000] Detected VIPT I-cache on CPU0
[ 0.000000] Speculative Store Bypass Disable mitigation not required
[ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 258048
[ 0.000000] Kernel command line: console=ttyMV0,115200 earlycon=ar3700_uart,0xd0012000 root=/dev/mmcblk1p1 rootwait rootflags=subvol=@,commit=5
[ 0.000000] PID hash table entries: 4096 (order: 3, 32768 bytes)
[ 0.000000] Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
[ 0.000000] Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
[ 0.000000] Memory: 1020272K/1048576K available (6910K kernel code, 446K rwdata, 2008K rodata, 320K init, 313K bss, 28304K reserved, 0K cma-reserved)
[ 0.000000] Virtual kernel memory layout:
[ 0.000000] modules : 0xffffff8000000000 - 0xffffff8008000000 ( 128 MB)
[ 0.000000] vmalloc : 0xffffff8008000000 - 0xffffffbebfff0000 ( 250 GB)
[ 0.000000] .text : 0xffffff8008080000 - 0xffffff8008740000 ( 6912 KB)
[ 0.000000] .rodata : 0xffffff8008740000 - 0xffffff8008940000 ( 2048 KB)
[ 0.000000] .init : 0xffffff8008940000 - 0xffffff8008990000 ( 320 KB)
[ 0.000000] .data : 0xffffff8008990000 - 0xffffff80089ff808 ( 447 KB)
[ 0.000000] .bss : 0xffffff80089ff808 - 0xffffff8008a4df08 ( 314 KB)
[ 0.000000] fixed : 0xffffffbefe7fb000 - 0xffffffbefec00000 ( 4116 KB)
[ 0.000000] PCI I/O : 0xffffffbefee00000 - 0xffffffbeffe00000 ( 16 MB)
[ 0.000000] vmemmap : 0xffffffbf00000000 - 0xffffffc000000000 ( 4 GB maximum)
[ 0.000000] 0xffffffbf00000000 - 0xffffffbf01000000 ( 16 MB actual)
[ 0.000000] memory : 0xffffffc000000000 - 0xffffffc040000000 ( 1024 MB)
[ 0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
[ 0.000000] Hierarchical RCU implementation.
[ 0.000000] CONFIG_RCU_FANOUT set to non-default value of 32
[ 0.000000] RCU restricting CPUs from NR_CPUS=4 to nr_cpu_ids=2.
[ 0.000000] RCU: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=2
[ 0.000000] NR_IRQS: 64, nr_irqs: 64, preallocated irqs: 0
[ 0.000000] GICv3: GIC: Using split EOI/Deactivate mode
[ 0.000000] GICv3: no VLPI support, no direct LPI support
[ 0.000000] GICv3: CPU0: found redistributor 0 region 0:0x00000000d1d40000
[ 0.000000] arch_timer: cp15 timer(s) running at 12.50MHz (phys).
[ 0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0x2e2049cda, max_idle_ns: 440795202628 ns
[ 0.000004] sched_clock: 56 bits at 12MHz, resolution 80ns, wraps every 4398046511080ns
[ 0.008413] Console: colour dummy device 80x25
[ 0.012923] Calibrating delay loop (skipped), value calculated using timer frequency… 25.00 BogoMIPS (lpj=125000)
[ 0.023570] pid_max: default: 32768 minimum: 301
[ 0.028417] Mount-cache hash table entries: 2048 (order: 2, 16384 bytes)
[ 0.035250] Mountpoint-cache hash table entries: 2048 (order: 2, 16384 bytes)
[ 0.043541] ASID allocator initialised with 32768 entries
[ 0.049110] Hierarchical SRCU implementation.
[ 0.053957] smp: Bringing up secondary CPUs …
[ 0.058874] Detected VIPT I-cache on CPU1
[ 0.058905] GICv3: CPU1: found redistributor 1 region 0:0x00000000d1d60000
[ 0.058936] CPU1: Booted secondary processor [410fd034]
[ 0.059016] smp: Brought up 1 node, 2 CPUs
[ 0.079722] SMP: Total of 2 processors activated.
[ 0.084561] CPU features: detected feature: GIC system register CPU interface
[ 0.091913] CPU features: detected feature: 32-bit EL0 Support
[ 0.097911] CPU features: detected feature: Kernel page table isolation (KPTI)
[ 0.107727] CPU: All CPU(s) started at EL2
[ 0.111864] alternatives: patching kernel code
[ 0.117094] devtmpfs: initialized
[ 0.122666] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ 0.132758] futex hash table entries: 512 (order: 4, 65536 bytes)
[ 0.139136] xor: measuring software checksum speed
[ 0.244037] 8regs : 1918.800 MB/sec
[ 0.344071] 8regs_prefetch: 1710.400 MB/sec
[ 0.444106] 32regs : 2358.800 MB/sec
[ 0.544141] 32regs_prefetch: 1984.400 MB/sec
[ 0.548808] xor: using function: 32regs (2358.800 MB/sec)
[ 0.554375] pinctrl core: initialized pinctrl subsystem
[ 0.560437] NET: Registered protocol family 16
[ 0.566080] cpuidle: using governor ladder
[ 0.570334] vdso: 2 pages (1 code @ ffffff8008744000, 1 data @ ffffff8008994000)
[ 0.578092] DMA: preallocated 256 KiB pool for atomic allocations
[ 0.585558] d0012000.serial: ttyMV0 at MMIO 0xd0012000 (irq = 9, base_baud = 0) is a mvebu-uart
[ 0.594482] console [ttyMV0] enabled
[ 0.594482] console [ttyMV0] enabled
[ 0.601804] bootconsole [ar3700_uart0] disabled
[ 0.601804] bootconsole [ar3700_uart0] disabled
[ 0.791372] raid6: int64x1 gen() 320 MB/s
[ 0.961363] raid6: int64x1 xor() 317 MB/s
[ 1.131532] raid6: int64x2 gen() 519 MB/s
[ 1.301526] raid6: int64x2 xor() 449 MB/s
[ 1.471632] raid6: int64x4 gen() 782 MB/s
[ 1.641673] raid6: int64x4 xor() 549 MB/s
[ 1.811728] raid6: int64x8 gen() 939 MB/s
[ 1.981821] raid6: int64x8 xor() 562 MB/s
[ 2.151964] raid6: neonx1 gen() 594 MB/s
[ 2.321973] raid6: neonx1 xor() 625 MB/s
[ 2.492030] raid6: neonx2 gen() 984 MB/s
[ 2.662115] raid6: neonx2 xor() 942 MB/s
[ 2.832201] raid6: neonx4 gen() 1312 MB/s
[ 3.002260] raid6: neonx4 xor() 1166 MB/s
[ 3.172328] raid6: neonx8 gen() 1296 MB/s
[ 3.342403] raid6: neonx8 xor() 1131 MB/s
[ 3.346545] raid6: using algorithm neonx4 gen() 1312 MB/s
[ 3.352119] raid6: … xor() 1166 MB/s, rmw enabled
[ 3.357069] raid6: using neon recovery algorithm
[ 3.362873] SCSI subsystem initialized
[ 3.367574] usbcore: registered new interface driver usbfs
[ 3.373328] usbcore: registered new interface driver hub
[ 3.378475] usbcore: registered new device driver usb
[ 3.384282] pxa2xx-i2c d0011000.i2c: could not find pctldev for node /soc/internal-regs@d0000000/pinctrl@13800/i2c1-pins, deferring probe
[ 3.397671] clocksource: Switched to clocksource arch_sys_counter
[ 3.409295] NET: Registered protocol family 2
[ 3.414259] TCP established hash table entries: 8192 (order: 4, 65536 bytes)
[ 3.421556] TCP bind hash table entries: 8192 (order: 5, 131072 bytes)
[ 3.428359] TCP: Hash tables configured (established 8192 bind 8192)
[ 3.434975] UDP hash table entries: 512 (order: 2, 16384 bytes)
[ 3.441130] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[ 3.447777] NET: Registered protocol family 1
[ 3.452135] RPC: Registered named UNIX socket transport module.
[ 3.458417] RPC: Registered udp transport module.
[ 3.462919] RPC: Registered tcp transport module.
[ 3.467780] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 3.475996] Crashlog allocated RAM at address 0x3f00000
[ 3.481200] workingset: timestamp_bits=46 max_order=18 bucket_order=0
[ 3.492078] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 3.498464] NFS: Registering the id_resolver key type
[ 3.503350] Key type id_resolver registered
[ 3.507768] Key type id_legacy registered
[ 3.512194] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.
[ 3.524110] io scheduler noop registered
[ 3.527845] io scheduler deadline registered (default)
[ 3.537189] mv_xor d0060900.xor: Marvell shared XOR driver
[ 3.598225] mv_xor d0060900.xor: Marvell XOR (Descriptor Mode): ( xor cpy intr )
[ 3.668216] mv_xor d0060900.xor: Marvell XOR (Descriptor Mode): ( xor cpy intr )
[ 3.676315] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 3.684518] cacheinfo: Unable to detect cache hierarchy for CPU 0
[ 3.693790] loop: module loaded
[ 3.702563] random: fast init done
[ 3.711390] m25p80 spi0.0: w25q64dw (8192 Kbytes)
[ 3.715939] 5 fixed-partitions partitions found on MTD device spi0.0
[ 3.722474] Creating 5 MTD partitions on “spi0.0”:
[ 3.727776] 0x000000000000-0x000000020000 : “secure-firmware”
[ 3.734377] 0x000000020000-0x000000180000 : “u-boot”
[ 3.740024] 0x000000180000-0x000000190000 : “u-boot-env”
[ 3.745752] 0x000000190000-0x0000007f0000 : “Rescue system”
[ 3.751854] 0x0000007f0000-0x000000800000 : “dtb”
[ 3.757415] moxtet spi0.1: Found SD Turris Mox CPU module
[ 3.762856] moxtet spi0.1: Peridot Switch module found
[ 3.768967] libphy: Fixed MDIO Bus: probed
[ 3.773296] libphy: orion_mdio_bus: probed
[ 3.778344] mv88e6085 d0032004.mdio-mii:10: switch 0x1900 detected: Marvell 88E6190, revision 1
[ 3.800884] libphy: /soc/internal-regs@d0000000/mdio@32004/switch0@10/mdio: probed
[ 3.832857] mvneta d0030000.ethernet eth0: Using device tree mac address d8:58:d7:00:ba:e8
[ 3.842505] mvneta d0040000.ethernet eth1: Using device tree mac address d8:58:d7:00:ba:e9
[ 3.851138] ehci_hcd: USB 2.0 ‘Enhanced’ Host Controller (EHCI) Driver
[ 3.857733] ehci-pci: EHCI PCI platform driver
[ 3.862451] ehci-platform: EHCI generic platform driver
[ 3.868008] ehci-orion: EHCI orion driver
[ 3.872227] orion-ehci d005e000.usb: EHCI Host Controller
[ 3.877838] orion-ehci d005e000.usb: new USB bus registered, assigned bus number 1
[ 3.885586] orion-ehci d005e000.usb: irq 13, io mem 0xd005e000
[ 3.917670] orion-ehci d005e000.usb: USB 2.0 started, EHCI 1.00
[ 3.923969] hub 1-0:1.0: USB hub found
[ 3.927510] hub 1-0:1.0: 1 port detected
[ 3.932111] uhci_hcd: USB Universal Host Controller Interface driver
[ 3.939383] usbcore: registered new interface driver usb-storage
[ 3.945747] i2c /dev entries driver
[ 3.950153] armada_37xx_wdt d0008300.watchdog: Initial timeout 120 sec, nowayout
[ 3.958272] sdhci: Secure Digital Host Controller Interface driver
[ 3.964668] sdhci: Copyright© Pierre Ossman
[ 3.969292] sdhci-pltfm: SDHCI platform and OF driver helper
[ 3.975007] xenon-sdhci d00d0000.sdhci: allocated mmc-pwrseq
[ 3.980863] xenon-sdhci d00d8000.sdhci: Got CD GPIO
[ 3.988958] NET: Registered protocol family 10
[ 3.994849] Segment Routing with IPv6
[ 3.998548] NET: Registered protocol family 17
[ 4.003096] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[ 4.016944] 8021q: 802.1Q VLAN Support v1.8
[ 4.020958] Key type dns_resolver registered
[ 4.027591] Btrfs loaded, crc32c=crc32c-generic
[ 4.036626] rtc-ds1307 0-006f: registered as rtc0
[ 4.041223] i2c i2c-0: PXA I2C adapter
[ 4.045812] mv88e6085 d0032004.mdio-mii:10: switch 0x1900 detected: Marvell 88E6190, revision 1
[ 4.067801] libphy: /soc/internal-regs@d0000000/mdio@32004/switch0@10/mdio: probed
[ 4.094118] DSA: switch 0 0 parsed
[ 4.097288] DSA: tree 0 parsed
[ 4.939607] mv88e6085 d0032004.mdio-mii:10 lan1 (uninitialized): PHY [!soc!internal-regs@d0000000!mdio@32004!switch0@10!mdio:01] driver [Marvell 88E6390]
[ 5.049610] mv88e6085 d0032004.mdio-mii:10 lan2 (uninitialized): PHY [!soc!internal-regs@d0000000!mdio@32004!switch0@10!mdio:02] driver [Marvell 88E6390]
[ 5.159611] mv88e6085 d0032004.mdio-mii:10 lan3 (uninitialized): PHY [!soc!internal-regs@d0000000!mdio@32004!switch0@10!mdio:03] driver [Marvell 88E6390]
[ 5.269612] mv88e6085 d0032004.mdio-mii:10 lan4 (uninitialized): PHY [!soc!internal-regs@d0000000!mdio@32004!switch0@10!mdio:04] driver [Marvell 88E6390]
[ 5.379608] mv88e6085 d0032004.mdio-mii:10 lan5 (uninitialized): PHY [!soc!internal-regs@d0000000!mdio@32004!switch0@10!mdio:05] driver [Marvell 88E6390]
[ 5.499609] mv88e6085 d0032004.mdio-mii:10 lan6 (uninitialized): PHY [!soc!internal-regs@d0000000!mdio@32004!switch0@10!mdio:06] driver [Marvell 88E6390]
[ 5.609610] mv88e6085 d0032004.mdio-mii:10 lan7 (uninitialized): PHY [!soc!internal-regs@d0000000!mdio@32004!switch0@10!mdio:07] driver [Marvell 88E6390]
[ 5.719610] mv88e6085 d0032004.mdio-mii:10 lan8 (uninitialized): PHY [!soc!internal-regs@d0000000!mdio@32004!switch0@10!mdio:08] driver [Marvell 88E6390]
[ 5.737046] xhci-hcd d0058000.usb: xHCI Host Controller
[ 5.742501] xhci-hcd d0058000.usb: new USB bus registered, assigned bus number 2
[ 5.750285] xhci-hcd d0058000.usb: hcc params 0x0a000998 hci version 0x100 quirks 0x0000000000010010
[ 5.759522] xhci-hcd d0058000.usb: irq 12, io mem 0xd0058000
[ 5.765821] hub 2-0:1.0: USB hub found
[ 5.769297] hub 2-0:1.0: 1 port detected
[ 5.773853] xhci-hcd d0058000.usb: xHCI Host Controller
[ 5.778921] xhci-hcd d0058000.usb: new USB bus registered, assigned bus number 3
[ 5.786818] xhci-hcd d0058000.usb: Host supports USB 3.0 SuperSpeed
[ 5.793429] usb usb3: We don’t know the algorithms for LPM for this host, disabling LPM.
[ 5.802079] hub 3-0:1.0: USB hub found
[ 5.805799] hub 3-0:1.0: 1 port detected
[ 5.810578] xenon-sdhci d00d0000.sdhci: allocated mmc-pwrseq
[ 5.877666] mmc0: SDHCI controller on d00d0000.sdhci [d00d0000.sdhci] using ADMA
[ 5.885571] xenon-sdhci d00d8000.sdhci: Got CD GPIO
[ 5.947851] mmc1: SDHCI controller on d00d8000.sdhci [d00d8000.sdhci] using ADMA
[ 5.956816] armada-37xx-rwtm-mailbox d00b0000.mailbox: Trust Status: 00000000
[ 6.086857] Turris Mox serial number
[ 6.091912] board version 22
[ 6.096035] burned RAM size 1024 MiB
[ 6.446942] rtc-ds1307 0-006f: setting system clock to 2019-04-03 14:48:07 UTC (1554302887)
[ 6.446944] random: crng init done
[ 6.577180] Waiting for root device /dev/mmcblk1p1…
[ 6.640778] mmc1: new ultra high speed SDR104 SDHC card at address aaaa
[ 6.648290] mmcblk1: mmc1:aaaa SA16G 14.8 GiB
[ 6.655921] mmcblk1: p1
[ 6.672058] BTRFS: device fsid db73f853-c20f-4d56-83ef-bd5de476384e devid 1 transid 23 /dev/root
[ 6.683578] BTRFS info (device mmcblk1p1): disk space caching is enabled
[ 6.690447] BTRFS info (device mmcblk1p1): has skinny extents
[ 6.707352] BTRFS info (device mmcblk1p1): enabling ssd optimizations
[ 6.718057] VFS: Mounted root (btrfs filesystem) readonly on device 0:13.
[ 6.726974] devtmpfs: mounted
[ 6.730389] Freeing unused kernel memory: 320K
[ 6.824339] init: Console is alive
[ 6.828235] init: - watchdog -
[ 7.100899] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[ 7.115778] gpio_button_hotplug: no symbol version for module_layout
[ 7.122460] gpio_button_hotplug: loading out-of-tree module taints kernel.
[ 7.131755] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[ 7.139959] init: - preinit -
[ 7.478253] mvneta d0030000.ethernet eth0: PHY [d0032004.mdio-mii:01] driver [Marvell 88E1510]
[ 7.487514] mvneta d0030000.ethernet eth0: configuring for phy/rgmii-id link mode
[ 7.498088] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[ 10.612856] mount_root: mounting /dev/root
[ 10.617811] BTRFS info (device mmcblk1p1): disk space caching is enabled
[ 10.627153] mount_root: loading kmods from internal overlay
[ 10.665841] kmodloader: loading kernel modules from //etc/modules-boot.d/*
[ 10.673958] kmodloader: done loading kernel modules from //etc/modules-boot.d/*
[ 11.028281] block: attempting to load /etc/config/fstab
[ 11.038658] block: extroot: not configured
[ 11.062179] urandom-seed: Seeding with /etc/urandom.seed
[ 11.103595] procd: - early -
[ 11.106645] procd: - watchdog -
[ 11.751499] procd: - watchdog -
[ 11.755543] procd: - ubus -
[ 11.812839] procd: - init -
Please press Enter to activate this console.
[ 11.921333] kmodloader: loading kernel modules from /etc/modules.d/*
[ 11.932284] zram: Added device: zram0
[ 11.944893] sit: IPv6, IPv4 and MPLS over IPv4 tunneling driver
[ 11.959217] ip6_tables: © 2000-2006 Netfilter Core Team
[ 11.972110] Netfilter messages via NETLINK v0.30.
[ 11.978384] ip_set: protocol 6
[ 12.008654] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
[ 12.016965] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
[ 12.060105] u32 classifier
[ 12.062647] input device check on
[ 12.066430] Actions configured
[ 12.071968] Mirror/redirect action on
[ 12.077802] sch_cake: Unknown symbol nf_conntrack_find_get (err 0)
[ 12.084352] sch_cake: Unknown symbol nf_ct_get_tuplepr (err 0)
[ 12.143532] Ebtables v2.0 registered
[ 12.150052] ip_tables: © 2000-2006 Netfilter Core Team
[ 12.176153] nf_conntrack version 0.5.0 (8192 buckets, 32768 max)
[ 12.185456] ctnetlink v0.93: registering with nfnetlink.
[ 12.270291] xt_time: kernel timezone is -0000
[ 12.292213] PPP generic driver version 2.4.2
[ 12.299720] NET: Registered protocol family 24
[ 12.321083] kmodloader: done loading kernel modules from /etc/modules.d/*
[ 13.670291] watchdog: watchdog0: nowayout prevents watchdog being stopped!
[ 13.677428] watchdog: watchdog0: watchdog did not stop!
[ 13.689771] watchdog: watchdog0: nowayout prevents watchdog being stopped!
[ 13.696912] watchdog: watchdog0: watchdog did not stop!
haveged: haveged starting up
[ 13.972358] zram0: detected capacity change from 0 to 522190848
[ 13.992141] Adding 509948k swap on /dev/zram0. Priority:-2 extents:1 across:509948k SS
haveged: haveged: ver: 1.9.4; arch: generic; vend: ; build: (gcc 7.3.0 CV); collect: 128K
haveged: haveged: cpu: (); data: 32K §; inst: 32K §; idx: 17/40; sz: 32712/75040
haveged: haveged: fills: 0, generated: 0
[ 16.213113] mvneta d0040000.ethernet eth1: configuring for 802.3z/1000base-x link mode
[ 16.222875] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 16.230664] mv88e6085 d0032004.mdio-mii:10 lan1: configuring for phy/ link mode
[ 16.240616] br-lan: port 1(lan1) entered blocking state
[ 16.246049] br-lan: port 1(lan1) entered disabled state
[ 16.255616] device lan1 entered promiscuous mode
[ 16.260141] device eth1 entered promiscuous mode
[ 16.280976] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 16.294994] mv88e6085 d0032004.mdio-mii:10 lan2: configuring for phy/ link mode
[ 16.303898] br-lan: port 2(lan2) entered blocking state
[ 16.309180] br-lan: port 2(lan2) entered disabled state
[ 16.322631] device lan2 entered promiscuous mode
[ 16.342578] mv88e6085 d0032004.mdio-mii:10 lan3: configuring for phy/ link mode
[ 16.354997] br-lan: port 3(lan3) entered blocking state
[ 16.360353] br-lan: port 3(lan3) entered disabled state
[ 16.375612] device lan3 entered promiscuous mode
[ 16.394509] mv88e6085 d0032004.mdio-mii:10 lan4: configuring for phy/ link mode
[ 16.403481] br-lan: port 4(lan4) entered blocking state
[ 16.408724] br-lan: port 4(lan4) entered disabled state
[ 16.423274] device lan4 entered promiscuous mode
[ 16.443204] mv88e6085 d0032004.mdio-mii:10 lan5: configuring for phy/ link mode
[ 16.453759] br-lan: port 5(lan5) entered blocking state
[ 16.459004] br-lan: port 5(lan5) entered disabled state
[ 16.491875] device lan5 entered promiscuous mode
[ 16.513521] mv88e6085 d0032004.mdio-mii:10 lan6: configuring for phy/ link mode
[ 16.523431] br-lan: port 6(lan6) entered blocking state
[ 16.528734] br-lan: port 6(lan6) entered disabled state
[ 16.560422] device lan6 entered promiscuous mode
[ 16.583968] mv88e6085 d0032004.mdio-mii:10 lan7: configuring for phy/ link mode
[ 16.598092] br-lan: port 7(lan7) entered blocking state
[ 16.603351] br-lan: port 7(lan7) entered disabled state
[ 16.628132] device lan7 entered promiscuous mode
[ 16.651956] mv88e6085 d0032004.mdio-mii:10 lan8: configuring for phy/ link mode
[ 16.661454] br-lan: port 8(lan8) entered blocking state
[ 16.666807] br-lan: port 8(lan8) entered disabled state
[ 16.719922] device lan8 entered promiscuous mode
[ 16.842875] mvneta d0030000.ethernet eth0: PHY [d0032004.mdio-mii:01] driver [Marvell 88E1510]
[ 16.884749] mvneta d0030000.ethernet eth0: configuring for phy/rgmii-id link mode
[ 16.892653] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 20.149178] mvneta d0030000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[ 20.157526] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Router Turris successfully started.

Good and loooooooooooooooooooooooooooooooooooooooooooooooong post.
Very good readable especially on mobile devices :frowning:

1 Like

Will you teach me a better way to embed a bootlog?

Please use [code][/code]

2 Likes

THX, it looks better now.

1 Like

or you can use something like this:

Summary

This text will be hidden

[details="Summary"]
This text will be hidden
[/details]
1 Like

The following steps helped me to successfully configure MOX Super Wired:

  1. Disconnect the MAX E module
  2. Installation of Turris OS from Cloud (Rescue Mode 6) to a separate MOX A module
  3. Completing the wizard after the first start
  4. Connect MOX E module
  5. Complete manual + Luci configuration
1 Like

After several reinstallations, I was able to make the serial console keyboard work.

I found that the IP address 192.168.1.1/24 is assigned to br-lan. But when plugged my computer into any port in MOX E module, it does not respond to ping or web acess (Foris).

root@turris:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E9
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E8
          inet6 addr: fe80::da58:d7ff:fe00:bae8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5984 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1584 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:1244143 (1.1 MiB)  TX bytes:141589 (138.2 KiB)
          Interrupt:10

eth1      Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E9
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:11

lan1      Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E9
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan2      Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E9
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan3      Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E9
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan4      Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E9
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan5      Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E9
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan6      Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E9
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan7      Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E9
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan8      Link encap:Ethernet  HWaddr D8:58:D7:00:BA:E9
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:120300 errors:0 dropped:0 overruns:0 frame:0
          TX packets:120300 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:16887091 (16.1 MiB)  TX bytes:16887091 (16.1 MiB)

Network config:

root@turris:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd9b:6bb6:5f73::/48'

config interface 'wan'
        option ifname 'eth0'
        option proto 'none'

config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option _turris_mode 'managed'

Did you read MOX section of: https://doc.turris.cz/doc/en/start ?

Yeah,

  • WAN port (eth0) from MOX A connected to internet connection
  • LAN port - my computer with static IP 192.168.1.10/24 connected to any port on MOX E
  • power on
  • waiting
  • see output from serial console
  • and still the IP address 192.168.1.1 does not respond

What is eth1 for? Is it a link for MOX E? Why do I still see it as “Link detected: no”?

root@turris:/# ethtool eth1
Settings for eth1:
        Supported ports: [ MII ]
        Supported link modes:   1000baseX/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  1000baseX/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: d
        Wake-on: d
        Link detected: no

Turris OS 4.0 alpha5 - The new version of Turris OS didn’t solve it.

When I use my procedure to install Turris OS on a separate MOX A module and then connect MOX E, I end up with this configuration. And all the ports work together.

eth1 have Link detected: yes

root@Turris:/# ethtool eth1
Settings for eth1:
        Supported ports: [ MII ]
        Supported link modes:   1000baseX/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  1000baseX/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: d
        Wake-on: d
        Link detected: yes
root@Turris:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde2:c6c3:2051::/48'

config interface 'wan'
        option proto 'none'

config interface 'lan'
        option type 'bridge'
        option proto 'dhcp'
        option _turris_mode 'unmanaged'
        option ifname 'eth0 lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8'

Then I am able to get MOX Super Wired into the “classic” expected and working configuration.

and eth1 still have Link detected: yes

root@Turris:/# ethtool eth1
Settings for eth1:
        Supported ports: [ MII ]
        Supported link modes:   1000baseX/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  1000baseX/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: d
        Wake-on: d
        Link detected: yes
root@Turris:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde2:c6c3:2051::/48'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option _turris_mode 'unmanaged'
        option bridge_empty '1'
        list ifname 'lan1'
        list ifname 'lan2'
        list ifname 'lan3'
        list ifname 'lan4'
        list ifname 'lan5'
        list ifname 'lan6'
        list ifname 'lan7'
        list ifname 'lan8'

Good job Turris team. I tested Turris OS 4.0 beta1 is released! and Turris OS installation and initial configuration using Foris wizard went perfectly and as expected.

1 Like

The same situation repeated with my new toy, MOX PowerWiFi. I had to disconnect every wifi finish install and setup the router.

Even when I disconnected everything and left only the MOX A module with hand-soldered WiFi device, the Rescue Mode 6 installation fails.

Turris team: Do you really mean it with the hand-soldered MOX A device? How do you want me to add more ordered modules +WiFi to my already used MOX A modules? Should I solder it myself?