MOX netboots but does not serve WiFi

I am netbooting my MOX - Pocket WiFi (no SD card inside) from
Turris OS version: 5.1.10 HBS

It is paired successfully, MOX shows up in Device list and everything is fine.

But the WiFi does not work. I can only see 4 APs (public and private networks on both 2.4 and 5GHz. The private one has hidden SSID) created by Omnia.

Foris shows:

MOX heartbeats OK.

This is my /etc/config/netboot (I want to use 5Ghz)
~# cat /etc/config/netboot
# WiFi specific settings
# 02df_9141 is MOX SDIO WiFi
# 168c_003c is WLE900VX - 5GHz AC PCIe WiFi card in MOX and Omnia

config device 02df_9141
        option channel 'auto5'
        option ssid '@@SSID@@'
        option key '@@KEY@@'

Any idea what’s wrong, what documentation I missed?
Thanks for help

I have the exact same problem, netbooting is successful but no Wifi from mox.

Did you have a look at their git already or contacted turris support and got an answer?

Do you have no settings to change as well in the “Remote Devices” section?
Like this:

EDIT 2: Here’s the corresponding ticket on their git instance for tracking.

Yeah, no settings to change.

I found ssh_key in /srv/turris-netboot/clients/accepted/<some_id>/
but wasn’t able to connect to mox using root, admin, turris-netboot, turris or netboot usernames. (EDIT - now I see the link you posted in the ticket - i will dig deeper soon)

Thanks for the ticket. I am now following it too. I didn’t know where to file it and relied on the forum first.

An update to this:
My Mox doesn’t load the firmware for both cards, I suspect this is the culprit for this.
Attached a log output from the mox after booting it, which clearly states “loading firmware failed for XXX”

This is what made the change for me:

# Defaults to be overridden later
config wifi default
         option ssid '@@SSID@@'
         option key '@@KEY@@'

You have to fill it. It is by the way described in the manual:

config wifi home
         option ssid 'homenet'
         option key 'home_sweet_home'

Good luck.


Thank you for your hint :slight_smile:

But this shouldn’t be necessary, it should import the first configured wifi automatically, that’s what in this documentation too and what I expect.
(I should give it a try anyway to see, if it’s just this simple issue or something else)

1 Like

Got a reply from support with three different options:

  • use the Mox in standalone mode with a config to bridge the LAN manually and use it as a full-fledged AP with webinterface etc.
  • wait for a solution while the support teams is trying to reproduce this issue and working on the opened ticket
  • try TOS 5.2 and see if it’s working with this version.

I’ll try 1) the next few days and hope that’ll be resolved later.

I was following the ticket 0regano filed - but the link is no longer valid. Is the issue private now?

Ad suggested solutions by support:

  1. I don’t want to use MOX in standalone mode - one of the selling points for MOX was it would be effortless WiFi signal extender.
  2. yeah, that sounds like a way to go. But the ticket disappeared. Do you know what happened to it?
  3. I prefer to stay on HBS, especially when Michal Hrusecky found issues as I saw in notifications to the ticket.

btw. Limiting charset to SSID and more importantly password sounds strange and should be avoided from security perspective.

But I will go ahead and try [a-zA-Z0-9] for SSID and password. Update coming soon.

UPDATE: Setting SSIDs and passwords to [a-zA-Z0-9] did not help - MOX has no WiFi.

It’s now confidential because of my wifi config, which I uploaded for further analysation, the issue is still there.

The only workaround what’s working until now is to set up the wifi adapters like @Michal_Smolak suggested, the default config and especially the variables are somewhat broken.

Any update on this?

I have the same problem with my nebooted Mox (running 5.1.10) and Omnia (running 5.2.0).

P.S. It seems like the OS version was not yet updated in netbooted devices.It was not my intention to run two different OS version.

I configured the WiFi on MOX manually as suggested above. This works fine as workaround.
Hopefully once the original issue is resolved, @0regano will let us know.

I’ll keep you posted.

Any update on this? I’ve been trying to get this to work since the very beginnning.

I tried the workaround @Michal_Smolak mentioned earlier, using only standard letters and numbers for SSID and password…; still the mox (power wifi with 8Lan extension) is not showing any WiFi-Signal. It IS connected to the Omnia as shown via netboot-manager list. I´ve factory reset it several times, but still nothing. Weird. Why should it work for your Mox, then? Did you #out any other lines of the config? are you using only one of the two WiFi adapters of the Mox?


PS: the omnia is on TOS 5.3.4

I fell back to manual configuration with identical SSID and password. No netboot unfortunately.

1 Like

ok, thanks for the clarification. for now, the “netboot” mode seems to be extremely experimental; I also believe it is the reason for one of my two MOX to not being flash-able anymore, it can´t be reset, nothing… so I would not recommend trying the netboot at this state at all, just in case anyone reads this.


any update on this? Just bought MOX pocket wifi and i ran into same issue. editing netboot config is a hit and miss for me, sometimes it works, sometimes after some restarts it does not .

well, i switched back to “regular” AP mode by manually configuring the mox. works fine, and in the end this took less time than to fix the weird netboot mode.