MOX: how to netboot?


#1

Hi, my MOX A arrived today. I want to netboot it from my Omnia. How do I proceed? There’s no documentation for this. I assume this should work without an SD card, right?

In foris on Omnia (with OS 3.11) I checked the netboot package list, but there’s no new menu item in Foris (I’m even pretty sure it was there in past, but now it’s gone).


#2

Here is a lecture from Installfest 2019
(only czech)

In Foris (TurrisOS 3.11.4) I have list of packages Turris MOX network boot


#3

Hello,

In the package, which you receive, there should be a manual, which should lead to our documentation. There was added article for Network boot.

Do you have the latest release of Turris OS 3.11.4?


#4

I have the same problem.
Turris Omnia rtrom01
Turris OS version 3.11.4
foris version: 99.7.5

No new tab in foris UI appeared after installing packages (Updater -> Turris MOX network boot).

##### Oznámení o aktualizacích #####
 • Nainstalovaná verze 0.1-3.6-1 balíku foris-controller-subordinates-module
 • Nainstalovaná verze 1.9.0-3.6-2 balíku python3-six
 • Nainstalovaná verze 0.1.9-3.6-1 balíku python3-pyasn1
 • Nainstalovaná verze 2.1-3.6-1 balíku python3-idna
 • Nainstalovaná verze 3.8-3.6-3 balíku python3-ply
 • Nainstalovaná verze 2.14-3.6-3 balíku python3-pycparser
 • Nainstalovaná verze 1.5.2-3.6-2 balíku python3-cffi
 • Nainstalovaná verze 1.10.0-1 balíku python-six
 • Nainstalovaná verze 2.7.12-10 balíku python-xml
 • Nainstalovaná verze 2.7.12-10 balíku python-unittest
 • Nainstalovaná verze 2.7.12-10 balíku python-sqlite3
 • Nainstalovaná verze 2.7.12-10 balíku python-pydoc
 • Nainstalovaná verze 2.7.12-10 balíku python-openssl
 • Nainstalovaná verze 2.7.12-10 balíku python-ncurses
 • Nainstalovaná verze 2.7.12-10 balíku python-gdbm
 • Nainstalovaná verze 2.7.12-10 balíku python-email
 • Nainstalovaná verze 2.7.12-10 balíku python-distutils
 • Nainstalovaná verze 2.7.12-10 balíku python-decimal
 • Nainstalovaná verze 2.7.12-10 balíku python-db
 • Nainstalovaná verze 2.7.12-10 balíku python-ctypes
 • Nainstalovaná verze 2.7.12-10 balíku python-compiler
 • Nainstalovaná verze 2.7.12-10 balíku python-codecs
 • Nainstalovaná verze 2.7.12-10 balíku python
 • Nainstalovaná verze 22.0.5-1 balíku python-setuptools
 • Nainstalovaná verze 0.1.9-1 balíku python-pyasn1
 • Nainstalovaná verze 1.0.16-1 balíku python-ipaddress
 • Nainstalovaná verze 2.1-1 balíku python-idna
 • Nainstalovaná verze 1.1.2-1 balíku python-enum34
 • Nainstalovaná verze 3.8-3 balíku python-ply
 • Nainstalovaná verze 2.14-3 balíku python-pycparser
 • Nainstalovaná verze 1.5.2-2 balíku python-cffi
 • Nainstalovaná verze 1.3.1-1 balíku python-cryptography
 • Nainstalovaná verze 16.0.0-2 balíku python-pyopenssl
 • Nainstalovaná verze 1.7.2-3.6-1 balíku python3-cryptography
 • Nainstalovaná verze 2018.03-5 balíku uboot-mkimage
 • Nainstalovaná verze 1.4.6-2 balíku dtc
 • Nainstalovaná verze 0.4.1.1-1 balíku turris-netboot-tools
 • Nainstalovaná verze 0.2-3.6-1 balíku foris-controller-netboot-module
 • Nainstalovaná verze 0.1-3.6-1 balíku foris-subordinates-plugin
 • Nainstalovaná verze 0.1-3.6-1 balíku foris-subordinates-plugin-l10n-cs
 • Nainstalovaná verze 0.1-3.6-1 balíku foris-subordinates-plugin-l10n-de

I can’t see a pairing request anywhere in foris UI…


#5

Same problem here - No new tab in foris UI appeared after installing packages (Updater -> Turris MOX network boot).

Device Turris Omnia - rtrom01
Serial number 47244667745
Turris OS version 3.11.4
Kernel version 4.4.178-7bc33afbb1b35f5830b2b1b42c9cd8a0-0

#6

I have the same problem…

I´ve installed the package in foris but no new tab.

And I also have no luck with connect directly to the pc.
When I set the IP Adress on my PC to 192.168.1.2 and the Gateway to 192.168.1.1 I have no chance to connect to the Turris Mox


#7

Same problem here - followed netboot guide, no new tab appears, no pairing requests seen :frowning:


#8

I’ve same problem. Also in advance I tried look at some netboot scripts in Omnia and found this, maybe it would be useful.

netboot-manager regen
tar: ./usr/share/turris-netboot/initrd-aarch64: Not found in archive
tar: ./usr/share/turris-netboot/mox.its: Not found in archive
tar: Exiting with failure status due to previous errors
Wrong rootfs

#9

Same issue. have tried factory reset and reinstalling the Mox package on Omnia, with no luck. No menu option on Foris, no notifications and the device is not picked up by a Figbox monitoring new devices on the network, so not booting up (network lights, etc., work, so power is good)


#10

Not better after update to 3.11.5 RC.


#11

We are so sorry for the missing tab in administration interface Foris. Can you please try now the RC version of Turris OS 3.11.5 and let me know if it works for you guys? The tab should be there.


#12

Hello Pepe,

I´ve updated to 3.11.5 RC but there is no tab there.
I´ve tried some reboots, deinstalled the package and install it again, but no new tab.
Any Ideas?

Gerät Turris Omnia
Seriennummer 47244684190
Turris OS Version 3.11.5
Kernelversion 4.4.180-a890a5a94ebb621f8f1720c24d12fef1-0

Bernd


#13

Didn’t have time to check UI, but

netboot-manager regen now works, AP is able to download boot image and I was able to netboot-manager accept , omnia created mox_ boot image

After reboot mox_ is downloaded from tftp and mox is connecting to ssh periodicaly in one minute internal

2019-06-10 10:08:52 info sshd[14790]: Accepted publickey for turris-netboot from x.x.x.x port 55846 ssh2: ED25519 SHA256:…
2019-06-10 10:08:52 info sshd[14792]: Received disconnect from x.x.x.x port 55846:11: disconnected by user
2019-06-10 10:08:52 info sshd[14792]: Disconnected from user turris-netboot x.x.x.x port 55846

But it seems AP is not working. There are two fast blinks of diod every cca 1sec.


#14

Hello,

I see. Thank you for confirming. @miska was able to find what is going on here and find why you don’t have the tab as we have it on our side. He fixed it as well and it will be included in the upcoming RC version of Turris OS 3.11.5, which we will release really soon.


#15

I’m not convinced that fix fully resolves this. I’ve updated to the nightly branch (where git-hash matches his commit and it’s still not working.

Nightly hash: https://repo.turris.cz/omnia-nightly/git-hash
Which shows his commit here: https://github.com/CZ-NIC/turris-os/commit/e361b5db5c8610b0686edb3059e5193b1c583d22

Rebooted my Omnia, still nothing. Possibly relevant is I have an unmanaged switch between my Mox and Omnia.


#16

I’m on RC2, rebooted, still nothing. What’s the URL of the netboot page? Maybe it’s just not showing in the menu…


#17
root@turris:~# netboot-manager regen
chown: unknown user/group turris-netboot:turris-netboot
chown: unknown user/group turris-netboot:turris-netboot
chown: unknown user/group turris-netboot:turris-netboot
chown: unknown user/group turris-netboot:turris-netboot
chown: unknown user/group turris-netboot:turris-netboot
chown: unknown user/group turris-netboot:turris-netboot
root@turris:~# useradd turris-netboot
useradd: user 'turris-netboot' already exists
root@turris:~# groupadd turris-netboot
root@turris:~# netboot-manager regen
root@turris:~#

#18

Manual connection now at least partly works:

root@turris:~# netboot-manager list-incoming
Incoming:
 * xxxx

root@turris:~# netboot-manager accept  xxxx
root@turris:~# netboot-manager list-incoming
Incoming:

root@turris:~# netboot-manager list-accepted
Accepted:
 * xxxx

root@turris:~# netboot-manager list
Accepted:
 * xxxx

Incoming:

Transfering:

root@turris:~# arp -a
IP address       HW type     Flags       HW address            Mask     Device
...
192.168.18.192   0x1         0x2         xx:xx:xx:xx:xx:xx     *        br-lan
^ this is the MOX

But I don’t know what next. Wifi scanner doesn’t show any new AP. MOX blinks 2 blinks fast, then a pause, then 2 blinks again (are there docs for the LED signals?). I can ping the MOX, but I can’t e.g. ssh to it (what’s the password? why doesn’t it have passwordless login from Omnia set up?). Ports 80 and 443 are also silent. And still no netboot tab in foris (even after accepting the MOX).


#19

Relevant plug-in seems to be here: https://gitlab.labs.nic.cz/turris/foris-subordinates-plugin

I see a few “slug” variables in there, but still not accessible for me yet.


#20

That’s same behaviour I have and described earlier with part of log… with no reaction :slight_smile: