Mmcblk0p1 mysteriously full

Hi Guys,

I’m appealing to the community for help, because I can’t figure out what’s filling up my emmc. I tried looking at this thread:100% usage on mmcblk0p1, but that doesn’t actually appear related to my problem. I first noticed a problem when programs stopped working, which prompted me to investigate and find that my / partition (on emmc) was 100% full. I managed to get some space to get things working again by deleting all but 1 schnapps snapshot, but obviously that’s not a permanent solution. Now I’m at about 92% of capacity, with df -h claiming I’m using 6.8 gb. I’ve run ncdu on the / partition, however, and as far as I can tell, with the exception of mounted drives (which I’ve checked, and are all legitimately mounted, not stored locally), I’m only using about 2gb of emmc space.

Anyone have an idea what’s going on, or a way to diagnose and/or find this ghost data that’s clogging my flash memory?

Thanks in advance!

Chris

Try to have a look at this post This way you can check the size of individual snapshots. It might be that some of the snapshots takes too much space.

Radekpribyl,

You may be on to something there, thanks for the link. I’m not sure what I’m looking at, though, to be honest. As I said, I deleted all but 2 of my snapshots, but running the following commands yields:

btrfs subvolume list /
ID 258 gen 5749 top level 5 path @factory
ID 260 gen 470261 top level 5 path certbackup
ID 273 gen 2951769 top level 5 path @
ID 301 gen 2929208 top level 5 path @33

and then

btrfs qgroup show /
qgroupid rfer excl


0/5 4.00KiB 4.00KiB
0/258 97.26MiB 46.46MiB
0/260 36.00KiB 36.00KiB
0/273 3.47GiB 338.43MiB
0/301 6.31GiB 3.17GiB

I’m not sure what these numbers mean, but from looking at the post you referred me to, I’m wondering what these figures mean–as if I’m correct, id 301 is the schnapps process.

The other clue that I have are these error messages I receive (unfortunately it looks like it’s gone in PuTTy, so I can’t quote it exactly), which indicate that the volume size is inaccurate and should be rescanned.

For instance, when using ncdu in /, I get “Warning: error scanning /proc/25365/fdinfo/3 some directory sizes may be incorrect”. The damnable thing is that the number (25365) will change each time I run ncdu. Clearly something is screwy. Does any of this help diagnose what’s going on?

Thanks for your help!

Chris

An interesting development, in case anyone reads this for help. I had midnight commander installed (opkg mc), which didn’t work correctly (I’d start it and nothing worked.) This is a fairly small program. Well, I thought, since I’m trying to get rid of as much space as possible, I’ll remove that non-functional bit of code. To my utter surprise, removing it freed up about 3 gigabytes of room. Not sure what the hell that was all about, but too happy to ask questions or experiment with it.

@thoggy the 0/301 is the ID of the subvolume the first is parent volumeid and second is the actual volume id. As you can see from the output of btrfs subvolume list the ID 301 is for the schnapps volume called @33

The disk space - I might not be 100% accurate with the terminology however keep in mind that the snapshots can “share” files which haven’t changed between the snapshots. So the sizes shows you total snapshot size and size unique to the snapshot. E.g. taking the snapshot/volume id 301 - there is 6.31GiB in total size and 3.17GiB unique. So if you deleted this snapshot you would free up 3.17GiB

Hopefully that helps.