Migrace updateru - segmentation fault

Bohužel se mi na Turris 1.1 nezdařila migrace updateru. Vždy to skončí výsledkem segmentation fault. Nevíte někdo co s tím? Obávám se, že se mi turris, již delší dobu neupdatuje.

Zde výpis ze spuštění updater-migrate.sh
root@turris:/etc/updater# updater-migrate.sh

  • grep -q -e – Auto-migration performed /etc/updater/auto.lua
    grep: /etc/updater/auto.lua: No such file or directory
  • BATCH=
  • uci -q get updater.override.branch
  • true
  • BRANCH=
  • [ -z ]
    • grep ^src/gz.*/base$sed -e s#.openwrt-repo/##;s#/.##
      /etc/opkg/distfeeds.conf
  • BRANCH=src
    • sed -e s/^omnia-//;s/^turris-//
      echo src
  • BRANCH=src
  • [ src = turris -o src = omnia ]
  • [ src ]
  • uci set updater.override=override
  • uci set updater.override.branch=src
  • uci commit updater
  • pkgmigrate --exclude=updater --exclude=updater-migrate --exclude=updater-deps --exclude=updater-consolidator --exclude=libelf --exclude=mtd-utils-flash-info --exclude=kmod-ipt-nathelper --exclude=6relayd --exclude=kmod-ipv6 --exclude=init-thermometer --exclude=kmod-crypto-aes --exclude=kmod-crypto-core --exclude=luci-i18n-czech --exclude=luci-i18n-english --exclude=coova-chilli --exclude=libevent --exclude=libmysqlclient --exclude=libncursesw --exclude=r8196-firmware --exclude=r8188eu-firmware --exclude=userspace_time_sync --exclude=foris-oldconfig
    Segmentation fault

2018-05-01T21:34:03+02:00 info kernel[]: [27532.396248] pkgmigrate[27908]: unhandled signal 11 at 2d0c6e46 nip b7aab5a4 lr b7aab690 code 30001

verze OS: 3.10
kerner: 4.4.131-fea04ecaf4d3e8a8c81b9e278dafea4f-2

Díky.

Mám stejný problém, pkgmigrate končí na “Segmentation fault”, jak to dopadlo?

UPDATE: Nakonec jsem udělal toto (Turris 1.0 byl v.3.7.3):

– jenom updater-ng už novější verze;
a když si následně pkgupdate --batch stěžoval inconsistent: Requested package luci-app-pbx that is not available, jsem z konce /etc/updater/conf.d/opkg-auto.lua odmazal řádek Install(“luci-app-pbx”), když jsem mezitím opkg remove luci-app-pbx.
Vůbec nevím, co jsem to udělal, :wink: ale teď jsem na v.3.10.2.