Medkit restore (4 leds) on Omnia hangs

For a long time the auto update feature on Omnia failed many times. Thus I decided to go through medkit image file restore on USB flash. I have copied the file to FAT32 USB root and inserted to Omnia. Hold down the reset button until the 4 red leds. Then I kept router running and went away. I came after 20 minutes and all led shine orange-red colour and nothing seems to happen. After one hour still the same status. Omnia seems hanged. Any idea what does this mean and what to do? Thanks.

What kind of failure?

Was it something like “read only filesystem”? If so it’s most probable that it’s flash failure.

Have you been using lxc without external storage?

All I can see is all LEDs hangs at orange/red colour right after setting the router into 4 LED restore status. I guess it is the update failure indication, most probably it is not even able to read the image or something. I tried it just few times, without being successful.

I went directly using this tutorial for 4 LEDs.

No. I was asking about your updater errors. Not about flash errors. You should have those in emails sent to you by router (of course only if you had notifications configured).

You case is consistent with following topic: 3.8.5 cant acces foris after update - router dont respond after factory reset

I have been able to get to the web interface and I see this error:

Error from 2017/11/17 14:52:00
Updater failed:
unreachable: /tmp/crl.pem: No such file or directory

so I tried to ssh into router and ran command get-api-crl which resulted in following errors:
Error relocating /usr/bin/curl: curl_mime_type: symbol not found
Error relocating /usr/bin/curl: curl_mime_data: symbol not found
Error relocating /usr/bin/curl: curl_mime_data_cb: symbol not found
Error relocating /usr/bin/curl: curl_mime_name: symbol not found
Error relocating /usr/bin/curl: curl_mime_encoder: symbol not found
Error relocating /usr/bin/curl: curl_mime_headers: symbol not found
Error relocating /usr/bin/curl: curl_mime_init: symbol not found
Error relocating /usr/bin/curl: curl_mime_filedata: symbol not found
Error relocating /usr/bin/curl: curl_mime_free: symbol not found
Error relocating /usr/bin/curl: curl_mime_filename: symbol not found
Error relocating /usr/bin/curl: curl_mime_subparts: symbol not found
Error relocating /usr/bin/curl: curl_mime_addpart: symbol not found

Any ideas now?

Yep. That is broken curl version. You have to reinstall both curl and updater-ng. But because they are all using curl it might be little bit more tricky. You can use wget to download needed packages from and install them using something like this: opkg-trans -a curl*.ipk -a updater-ng*.ipk.

Thanks. I finaly gave up and have been able to restore to factory defaults. All working now, but I am on version 3.2.1 :-/ I tried to run opkg update in ssh but get SSL error so I installed but it did not help. Is there any straightforward guide how to update to 3.8.5? Automatic updater seem to fail due to SSL error too. Thanks.

Use updater! opkg is not primary packaging tool in Turris OS, updater-ng is. Run

Many thanks @cynerd, all seems fine now! Have a great weekend.

1 Like