LXC templates: Fedora and Centos support?

What about the other LXC templates which are not listed in the GUI? Are they unsupported or is it possible to use them?

I tried to install lxc-fedora and lxc-centos from comman line but both gave me errors.


Fedora did not work because of some missing “squashfs” support.

Fedora Master Mirror Servers

Modules for Fedora Core and Extras have been removed, as this content is
no longer updated. See the instructions below for how to mirror current

See http://fedoraproject.org/wiki/Infrastructure/Mirroring for

receiving incremental file list

sent 59 bytes received 210,007,563 bytes 5,915,707.66 bytes/sec
total size is 209,981,440 speedup is 1.00
Download of squashfs image complete.
mount: squashfs: mount failed: No error information

Mount of LiveOS squashfs image failed! You mush have squashfs support
available to mount image. Unable to continue. Correct and retry
process later! LiveOS image not removed. Process may be rerun
without penalty of downloading LiveOS again. If LiveOS is corrupt,
remove /var/cache/lxc/fedora/armhfp/LiveOS before rerunning to redownload.


Centos did not work because of a missing “dnsdomainname” command (which is as far as I know part of the hostname package which I could not find). Also yum would be needed which I also cannot find.

/usr/share/lxc/templates/lxc-centos: line 808: dnsdomainname: command not found
’yum’ command is missing

Still no answer for this? I am also interested in Fedora.

Is there some news about this? I really would like to setup CentOS or Fedora.

Hi guys,
unfortunately there is nothing, what we can do right now.
AFAIK Fedora and also CentOS doesn’t provide armv7l tarball rootfs.

But I don’t want to give you any promises on this, but we’re finding ways, how to have Fedora available in LXC container. (There is no guarantee that we’ll have it.)

If you have something related to this thread, let me know. I’ll open this thread.