Lxc-start: Failed to mount API filesystems

I’m a bit new to lxc, used Docker a bit more.
When I try to start and attach to a LXC it won’t work:

root@turris:~# lxc-start -F -n 03_borg --logfile=log.txt
Failed to mount cgroup at /sys/fs/cgroup/systemd: Operation not permitted
[!!!] Failed to mount API filesystems.
Exiting PID 1…

The logfile is empty.
I tried different kind of distributions and versions, Ubuntu and Debian. Same result.

When I run lxc-attach I get this:

root@turris:~# lxc-attach -n 03_borg
lxc-attach: 03_borg: attach.c: lxc_attach: 1095 Failed to get init pid

I found an ission on LXCs GitHub repo but to be honest I don’t really know what it means…
I used LuCIs standardconfig:

# Template used to create this container: /usr/share/lxc/templates/lxc-download
# Parameters passed to the template: --dist ubuntu --release hirsute --arch armhf --server images.linuxcontainers.org --no-validate
# For additional config options, please look at lxc.container.conf(5)

# Uncomment the following line to support nesting containers:
#lxc.include = /usr/share/lxc/config/nesting.conf
# (Be aware this has security implications)

# Debian workaround
# Template to generate fixed MAC address

# Distribution configuration
lxc.include = /usr/share/lxc/config/common.conf
lxc.arch = linux32

# Container specific configuration
lxc.tty.max = 4
lxc.pty.max = 1024
lxc.rootfs.path = btrfs:/srv/lxc/03_borg/rootfs
lxc.uts.name = 03_borg

# Network configuration
lxc.net.0.type = veth
lxc.net.0.link = br-lan
lxc.net.0.flags = up
lxc.net.0.name = eth0
lxc.net.0.hwaddr = f2:d7:12:ff:80:85

Anyone here who can help me with that problem? I could even reset the whole router if someone could tell me how I keep my other settings in LuCI and my OpenVPN settings in ReForis… :smiley: I don’t find a simple save-config-button.


This is going to be fixed in a newer version of Turris OS, which is going to be released soon.

Great! Thank you for the quick reply! Is it already in one of the update channels or under construction? I wouldn’t mind going on the edge for a couple of weeks. :smiley:

1 Like

Yes, it is already available in HBK since Wednesday.

1 Like

Fixed in Turris OS 5.2.7, which was released this week.