Luci keeps logging out when navigating to Services > LXC-Containers TOS 5.1.2

I recently did a clean install of TOS 5.1.2. via a usb flash drive. The router had TOS V3 running beforehand. Everything went fine with flashing the v5 OS. But now I get logged out of luci every time I try to log in. It keeps producing either of the two messages:

I am using firefox, with edge the same errors occur.

I have not modified anything related to the luci interface. I’m at a loss here. Any pointers would be helpful.

EDIT Same errors happen after removing the luci package with all its dependencies and letting reinstall by the system.

EDIT Happens only when clicking System > LXC-Container

EDIT uninstalled lxc-container support via reforis, reinstalled it, same problem, clicking services > lxc-container kicks me out of the luci interface.

EDIT It wasn’t as clear to me until I noticed that it only happens when I try to go to Services > LXC Containers. I just got both the logout message and the corrupt config file message immediately after navigating to that section. Navigating to all other sections works fine.

Log in via ssh and post the output of:

cat /etc/config/luci

and

/etc/init.d/rpcd status
config core 'main'
        option lang 'auto'
        option mediaurlbase '/luci-static/bootstrap'
        option resourcebase '/luci-static/resources'
        option ubuspath '/ubus/'

config extern 'flash_keep'
        option uci '/etc/config/'
        option dropbear '/etc/dropbear/'
        option openvpn '/etc/openvpn/'
        option passwd '/etc/passwd'
        option opkg '/etc/opkg.conf'
        option firewall '/etc/firewall.user'
        option uploads '/lib/uci/upload/'

config internal 'languages'
        option cs 'Čeština (Czech)'
        option de 'Deutsch (German)'
        option en 'English'

config internal 'sauth'
        option sessionpath '/tmp/luci-sessions'
        option sessiontime '3600'

config internal 'ccache'
        option enable '1'

config internal 'themes'
        option Bootstrap '/luci-static/bootstrap'

config internal 'apply'
        option rollback '90'
        option holdoff '4'
        option timeout '5'
        option display '1.5'

config internal 'diag'
        option dns 'www.turris.cz'
        option ping 'www.turris.cz'
        option route 'www.turris.cz'

This just gives me an available commands list.

Ah, sorry, turris devices doesn’t seem to support status, try this one:

ps ax | grep rpc[d]
root@turris:~# ps ax | grep rpc[d]
 7824 ?        S      0:00 /sbin/rpcd -s /var/run/ubus.sock -t 30

Sorry, can’t reproduce your issue with turris mox 5.2 (and your config).

Just try an rpcd restart: /etc/init.d/rpcd restart
And please re-try with a browser like chrome.

Neither suggestion helps.

I just noticed that the logout happens when I click on Services > LXC-Container.

EDIT uninstalled lxc-container support via reforis, reinstalled it, same problem, clicking services > lxc-container kicks me out of the luci interface

Well, that’s an important information - originally I thought you can’t login in luci at all.
LXC is typically located under “Services” => “LXC Containers”, and not under “System”. Is it really in the latter menu in your installation?

Of course it is under Services, my mistake. It wasn’t as clear to me until I noticed yesterday that it only happens when I try to go to Services > LXC.Container. I just got both the logout message and the corrupt config file message immediately after navigating to that section. Navigating to all other sections works fine.

OT:/
This is not technically correct. This function is only available in OpenWrt snapshots (master branch for now) since this commit:

I’ve just tried it on the HBD branch on Turris Omnia:

root@turris:~# /etc/init.d/rpcd status
running
1 Like

It resolved itself with router updates. shrugs