Low bandwith MOX AP

I’ve setup a master Turris Omnia & a MOX AP using the guide at: https://docs.turris.cz/basics/apps/netboot.

Unfortunately, it seems that the bandwith (when connected to the MOX 5Ghz) is really low ( a few Mbit/s ). Whereas a direct connection to the Omnia (5Ghz) gets me a whole lot more (in the hundreds).

Is there any obvious cause that could lead to this slowdown?

I’ve also been doing some trouble shooting bymodifying /etc/config/netboot on the omnia, this controls the network config of the MOX APs right?

config device 56*********_168c_003c
        option channel '40'
        option ssid 'network-name-clone'
        option key '@@KEY@@-5'
        option htmode 'VHT40'

This should make the MOX pop up with a new network right? Called network-name-clone, this isn’t happening though.

It’d probably help if you tell us what WiFi card you have. I.e. did you buy one of the prepared MOX sets (Basic, PowerWifi, Start, etc.), or did you somehow custom-build your own MOX? And what version of Turris OS are you running on the Omnia? From my experience, Turris OS 3.x isn’t really good at the netbooting and suffers various problems… Maybe 4.x or 5.x could do better?

Hi @peci1 thanks for the reply!

I got the Double MOX AP & Omnia Bundle from the crowdfund run.
So that would give the following spec:
MOX AP (access points with 2×2 MIMO 2,4/5 GHz dual-band switchable Wi-Fi)

I think this is now called the Mox Pocket Wi-Fi set.

I’ve checked my version and I’m on 3.x, time to update!

Unfortunately, that isn’t really working out for me.
I’ve created an ext4 usb drive with:

  • omnia-medkit-latest.tar.gz
  • omnia-medkit-latest.tar.gz.md5
  • omnia-medkit-latest.tar.gz.sha256
  • omnia-medkit-latest.tar.gz.sig

Which the omnia can read and mount in normal operation.

When I put the omnia in flash mode, it only briefly is in the “red” mode, and starts normal operation soon after (without updating).
Do you know what’s going on? Is there any additional info that would help with triage?

Try it again with FAT32 file system. Hash files are not needed.

@viktor it didn’t work :cry:

Same result.

I’m at 3.11.16, if that helps.

I’ve also tried the combination of ext4 and filename omnia-medkit-last.tar.gz which has the same result.

You can try the schnapps-based upgrade mentioned in Migrating to TOS 4 with schnapps . However, please, keep in mind that doing any kind of upgrade to Turris OS 4/5 will not migrate your configuration (yet) and you might lose all data on the router’s internal memory. Turris OS 4.x is production-ready, while Turris OS 5.x is in a kind of beta stage. It should be practically usable, though, for the majority of people.

Ok, the wifi card included with the pocket wifi is the SDIO version, which is known to be less performant than a regular mPCIe/m.2 card. However, it shouldn’t be painfully slow. You can also use a wifi scanner to see which channel does the MOX wifi use (you should recognize the MOX AP via its MAC address). The netboot channel selection algorithm is quite dumb and selects a random channel on boot regardless of the traffic on that channel. You can set a fixed channel in /etc/config/netboot.

Thanks. Quick question though, where can I find the turris os 4 image? I can’t seem to find a link to it (everythin links to latest)


@peci1 Thanks for the help! With your tip I was able to solve it.

To @otherpeople that (will) have the same problem that I had:

  • I downloaded Turris OS 4.0.6: https://repo.turris.cz/archive/4.0.6/medkit/omnia-medkit-latest.tar.gz
  • updating using schnapps was a breeze (schnapps import -f image.tar.gz && schnapps rollback factory followed by a reboot)
  • I’ve paired with another MOX (same kit) (I have the other still set up with the previous verrsion)
  • I found out that by default this kit (with netboot) seems to use 2.4Ghz
  • To fix this I changed /etc/config/netboot to have the following:
config device 02df_9141
        option channel 'auto5'

Previously the SIDO (only interface on this kit) was used with auto24 by default, which resulted in the network being 2.4Ghz.

In the end, with the upgrade & other MOX (while on 2.4Ghz) the bandwith went up to 65 Mbit/s (from an initial ~2Mbit/s).
The base omnia (on 5 Ghz) gives me 220 Mbit/s.
After the modification to /etc/config/netboot to enable 5 Ghz I’m at 115 Mbit/s on the MOX!

Now I’m sure there is future tweaking that could improve all of these a bit more, but the base issue is solved!

Glad to hear that! So you think the update of Omnia was the most important thing that helped?

There’s a thread MOX A SDIO Bandwidth stating that you could get 150 Mbit/s over SDIO wifi, but that depends on many things. You can start by checking the channel width (and if your measuring device supports 80 MHz channels).

Hi, I’m not 100% sure what the cause was. When I find the time, I’ll do some triaging to see whether it might have been the original MOX contributing to the slowness.