Lost VDSL bridge connectivity after 7.0 update

My Omnia has two issues after the 7.0 update:

  1. Admin web-interfaces stopped working, as reported here: 7.0 cannot open web interface

  2. I thought my old modem (i.e. router in bridge mode) stopped working and so I lost my Internet connection. I went on, attempting to finally replace it with a newer device I’ve had here waiting. That is when noticed I cannot access LuCI, nor ReForis, which is when I noticed there was an update and only now do I realize, it is not that my modem stopped working but rather that Turris borked my setup

It seems to me, a kernel module went missing: ppp_generic.

Could somebody please help me

  • get my Omnia connected to internet through my ISP Comtrend router (not in bridge mode), using only ssh?
  • Or mybe point me to package/s I need to put onto Omnia for it to start working again?
  • Or suggest some other solution?

I have such issues in cases like - modem <> router WAN port connection is cut due to cable being disconnected or simply connections not being properly strong.
Also I got this during the outage when modem did not have connection with the ISP due to their infrastructure cabling again being cut by road constuction

It takes minutes for it to come back. sometimes I restart modem and restart wan interface.

but the signalization in logs is poorly documented. not self-evident and problematic. that I can confirm.

USER REQUEST ERROR YOU GOT - please do what I did. restart wan IF (interface)+ restart modem + check your cabling between these two

Naaaah that is clearly not compiled module.

This is what preceded the screenshot:
I tried ifup wan and it told me to you need to create the /dev/ppp device node... as seen in the log, so I ran that command
mknod /dev/ppp c 108 0

Another ifup wan then complained Please load the ppp_generic kernel module

So I downloaded the kmod pppoe package from here Index of /hbs/omnia/packages/core/ and this is my unsuccessful attempt at installing it. I am confused:

root@turris:/srv# opkg install kmod-pppoe_5.15.148-1-cfaf0eaef6d040cba91b2530b83dd2ac_arm_cortex-a9_vfpv3-d16.ipk
Package kmod-pppoe (5.15.147-1-b8434caa71ddf67be2a85c68821f95a9) installed in root is up to date.
Collected errors:
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.148-1-cfaf0eaef6d040cba91b2530b83dd2ac) for kmod-pppoe
root@turris:/srv# uname -a
Linux turris 5.15.148 #0 SMP Tue Apr 2 01:04:13 2024 armv7l GNU/Linux

What about just opkg update && opkg install kmod-pppoe?

I do not have internet without a working modem… I just restored a pre-update snapshot with schnapps however - I forgot there is such a thing! LuCI started working again too. I will try to put the provider router into bridge mode hopefully soon

To keep you updated, in the end I reverted to a pre-update schnapps snapshot and let Omnia update itself again. This time the 7.0 works fine. My takeaway is that I was chosen as a beta tester in the staged update rollout system

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.