Kresd is disabled, but everything works. How?

Turris Omnia on Turris OS 3.11.8
Looking at the LuCI screen with active services, kresd seems to be disabled. But everything works and by using dnsleaktest.com I can see the only server selected in Foris as expected. How does it work then?

It seems to be a bug in LuCI or something I don’t understand. In fact on htop the service is active in memory.

There is also resolver enabled and running and its starting kresd anyway.

Yoy can see by yourself:
/etc/init.d/resolver restart

1 Like

Do resolver enable kresd?

Yes. Resolver starts kresd.

Thank you very much.