Kernel update causes a reboot loop

Hi - just fired up my new Turris Omnia and it tried to pick up a new kernel once I turned on automatic updates. Sadly booting into the new kernel locks the router up - it seems to be stuck in a reboot loop (I’m guessing based on what the LEDs are doing) and I cannot get an address from it (wired or wi-fi) so I can’t get into it to see what’s happening.

I can factory reset to get back to an out-of-the-box state, but obviously this is less than ideal. Has anyone else seen this problem? Does anyone know how to work around it or fix it?

The broken version is 4.4.38-1-efe609c5e5f25db4116d69128330872c-1

Finally found time over the holiday to fire up my Turris Omnia. Get the same issue, after each reboot the router still in a boot loop. It is also looks like

Just roll back to previous snapshot. No need for factory reset.

I couldn’t reach the internet to get the instructions on how to do that as my router was in a reboot loop and mobile coverage was flaky at the time.

In any case, that’s not actually addressing the problem: It would be nice not to have to turn off updates because I know the pending kernel update is going to hose the router again.

Agree. It’s quite annoying I have to disable the updater just to keep my configuration running.

i ran into somthing similar:
installed medkit-stable but /etc/opkg/distfeeds.conf contains url for a different branch
updater shoots itself in the head (throu your foot) first chance it gets …

So is there a fix for this? Can I exclude the kernel packages from automatic updates so I can at least get other updates?

I haven’t seen any reboot loops in any of the recent updates (just updated to 3.5.2 yesterday, which did patch the kernel)

Yes, but not everyone was seeing reboot loops with that kernel - I’m in the middle of debugging some weird ipv6 problem with my ISP and I don’t want to have to reconfigure everything - what’s the best way to recover from such a reboot loop without having to reconfigure? Can I take a snapshot and then boot back into it?

You can use “schnapps” from the command line to manage the snapshots:

View all existing snapshots:

schnapps list

Create a snapshot:

schnapps create "optional comment goes here"

Rollback to a prior snapshot:

schnapps rollback n; reboot

where n is one of the numbers from “schnapps list”

When you use rollback, the full state of the router (everything) gets rolled back to the point it was at when that snapshot was taken. It’s a really handy feature. The router also has a cron job that takes snapshots weekly if you have not before, and it also automatically takes snapshots before each automatic update to allow you to easily revert.

Even without command line access, you can rollback to prior snapshot using the reset instructions here: (2 LEDs mode)

If you’re trying anything risky, take a snapshot first…and there’s no reason to have to reconfigure if an update doesn’t work for you, just rollback to prior snapshot.

I see - thanks. I’ll take a snapshot, re-enable updates and see how it goes.