Kernel > 4.4 v Turris Omnia?


#1

Zdravím,

právě se snažím dostat do Omnie kmod-ipt-tee, nicméně balík anti-závisí na kernelu 4.4 (Depends on: !LINUX_4_4 [=y] ). Takže předpokládám, že cestou by mohlo být použití novějšího kernelu, než je 4.4. Plánuje se jeho integrace i do Turrisu? Případně má někdo zkušenost s kompilací novějšího kernelu?

Díky!


#2

Rozhodně plánuje. Už to tu na fóru bylo párkrát zmíněno; alenemám dobré informace kdy by to mohlo být ve -stable.


#3

No, zatím to není ani v test branchi na gitu :slight_smile: Na fóru jsem hledal, ale nenalezl jsem bohužel nic moc relevantního.


#4

To by me take zajimalo. Nedavno jsem na sve omnii zaznamenal crash ovladacu, ktere se pravidelne opakuje. Vzdy pri velke WiFi zatezi modul lehne.

Bud udelam back-port z aktualniho vanilla kernelu (coz bude radove snazsi), nez kompilace jine verze jadra. Ale nez se do toho pustim, tak bych take rad vedel, kdy zhruba se muze objevit nove jadro v omnia repo.


#5

Nějaká informace od Turris-týmu? Pár dnů zpátky byl v branchi posunut 4.4 kernel na aktuální release (.157) ale jinak nic. Chápu, že Mox, ale nějaká informace by se našla, ne? :slight_smile:


#6

Pravděpodobně to bude až s verzí 4.0. V aktuálním OpenWrt je teď 4.9 a 4.14.
Ale kdy bude verze 4.0 se zatím stále neví (alespoň ne oficiálně).