Issues setting up MWAN3 with LTE

Hello, I’m trying to setup Turris Omnia with fallback LTE connection with dongle HUAWEI E3372H-320. I have installed internal disk for NAS, so I cannot use the internal mPCIe slot.

The Huawei dongle in Hilink mode just appears to work out of the box - once connected, new interface eth3 gets added to Turris Omnia. I have configured it as “LTE” and assigned to firewall etc. based on the normal LTE setup guide and mwan3 guide Nastavení záložního připojení přes LTE pomocí mwan3 [Turris wiki].

While trying ping, it works fine:
Command:
ping -I ‘eth3’ -c 5 -W 1 ‘8.8.4.4’ 2>&1

Result:
PING 8.8.4.4 (8.8.4.4) from 192.168.8.104 eth3: 56(84) bytes of data.
64 bytes from 8.8.4.4: icmp_req=1 ttl=120 time=5.26 ms
64 bytes from 8.8.4.4: icmp_req=2 ttl=120 time=7.27 ms
64 bytes from 8.8.4.4: icmp_req=3 ttl=120 time=5.48 ms
64 bytes from 8.8.4.4: icmp_req=4 ttl=120 time=5.25 ms
64 bytes from 8.8.4.4: icmp_req=5 ttl=120 time=5.43 ms

--- 8.8.4.4 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4000ms
rtt min/avg/max/mdev = 5.254/5.742/7.278/0.773 ms

But after attempting to configure mwan3 with LTE as a failover for the main WAN connection, it simply doesn’t work and mwan keeps detecting it as “offline”. WHen unplugging the WAN cable, it doesn’t failover.
image

Could you please help me getting this to work?

 cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde8:cf11:15b8::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option bridge_empty '1'
        list ifname 'lan0'
        list ifname 'lan1'
        list ifname 'lan2'
        list ifname 'lan3'
        list ifname 'lan4'

config interface 'wan'
        option ifname 'eth2'
        option proto 'static'
        option ipaddr '10.16.x.y'
        option netmask '255.255.255.252'
        option gateway '10.16.x.z'
        list dns '8.8.8.8'
        list dns '10.255.255.10'
        option defaultroute '1'
        option metric '10'
        option ipv6 '1'

config interface 'guest_turris'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.111.222.1'
        option netmask '255.255.255.0'
        option bridge_empty '1'
        option enabled '1'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config interface 'LTE'
        option ifname 'eth3'
        option proto 'dhcp'
        option metric '50'
        option defaultroute '0'
        option vendorid 'turris'

MWAN3 Configuration:
# cat /etc/config/mwan3

config globals 'globals'
        option mmx_mask '0x3F00'
        option rtmon_interval '5'
        option enabled '1'

config interface 'wan'
        option enabled '1'
        list track_ip '8.8.4.4'
        list track_ip '8.8.8.8'
        list track_ip '208.67.222.222'
        list track_ip '208.67.220.220'
        option family 'ipv4'
        option reliability '1'
        option count '1'
        option timeout '2'
        option failure_latency '1000'
        option recovery_latency '500'
        option failure_loss '20'
        option recovery_loss '5'
        option interval '5'
        option down '3'
        option up '8'

config interface 'LTE'
        option enabled '1'
        list track_ip '8.8.4.4'
        list track_ip '8.8.8.8'
        list track_ip '208.67.222.222'
        list track_ip '208.67.220.220'
        option family 'ipv4'
        option reliability '1'
        option count '1'
        option timeout '2'
        option failure_latency '1000'
        option recovery_latency '500'
        option failure_loss '20'
        option recovery_loss '5'
        option interval '5'
        option down '5'
        option up '8'

config member 'wan_m1_w1'
        option interface 'wan'
        option metric '1'
        option weight '1'

config member 'lte_m2_w2'
        option interface 'LTE'
        option metric '2'
        option weight '2'

config policy 'wan_lte'
        list use_member 'wan_m1_w1'
        list use_member 'lte_m2_w2'
        option last_resort 'unreachable'

config rule 'default_rule_v4'
        option dest_ip '0.0.0.0/0'
        option use_policy 'wan_lte'
        option proto 'all'
        option sticky '0'
        option family 'ipv4'