ISP require VLAN id = 101


#1

Hi

I have asked my Internet Service Provider (ISP) how I could connect my Turris Omnia 1.1 directly to cable and by pass the ISP router. They said: Just put it in VLAN ID with the identifier ‘101’ and connect it. Either I’m doing wrong or it does not work.

My ISP renew the DHCP lease every 2 hours so I have set the MAC address to the same as the ISP has. Otherwise I had to wait 2 hours to be sure it asked for a new lease time.

Here is what I have in my /etc/config/network

config interface 'wan'
    option ifname 'eth1'
    option proto 'dhcp'
    option macaddr '8C:59:73:74:17:9A'
    option vlan '3'
    option vid '101'
    option hostname 'turris'

Then I give it a reboot and connect the WAN cable during that. No connection established.

Then I tried to reboot without WAN, then logged in and made ‘tcpdump -i eth1 -vvv’ on eth1 while connecting the cable:

7:28:48.430785 IP6 (hlim 1, next-header Options (0) payload length: 96) fe80::8e59:73ff:fe74:179a > ff02::16: HBH (rtalert: 0x0000) (padn) [icmp6 sum ok] ICMP6, multicast listener report v2, 4 group record(s) [gaddr ff02::1:ff00:0 to_ex { }] [gaddr ff02::1:ff74:179a to_ex { }] [gaddr ff05::2 to_ex { }] [gaddr ff02::2 to_ex { }]

17:28:48.500732 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from 8c:59:73:74:17:9a (oui Unknown), length 300, xid 0xca88817b, Flags [none] (0x0000)
Client-Ethernet-Address 8c:59:73:74:17:9a (oui Unknown)
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: Discover
MSZ Option 57, length 2: 576
Parameter-Request Option 55, length 8:
Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
Domain-Name, BR, NTP, Option 212
Vendor-Class Option 60, length 12: “udhcp 1.25.1”
Hostname Option 12, length 6: “turris”
END Option 255, length 0
PAD Option 0, length 0, occurs 20

Should I expect to see the VLAN ID in the above?

7:28:48.430785 IP6 (hlim 1, next-header Options (0) payload length: 96) fe80::8e59:73ff:fe74:179a > ff02::16: HBH (rtalert: 0x0000) (padn) [icmp6 sum ok] ICMP6, multicast listener report v2, 4 group record(s) [gaddr ff02::1:ff00:0 to_ex { }] [gaddr ff02::1:ff74:179a to_ex { }] [gaddr ff05::2 to_ex { }] [gaddr ff02::2 to_ex { }]

17:28:48.500732 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from 8c:59:73:74:17:9a (oui Unknown), length 300, xid 0xca88817b, Flags [none] (0x0000)
Client-Ethernet-Address 8c:59:73:74:17:9a (oui Unknown)
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: Discover
MSZ Option 57, length 2: 576
Parameter-Request Option 55, length 8:
Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
Domain-Name, BR, NTP, Option 212
Vendor-Class Option 60, length 12: “udhcp 1.25.1”
Hostname Option 12, length 6: “turris”
END Option 255, length 0
PAD Option 0, length 0, occurs 20

What could I test now?


#2

try removing option vlan and vid lines and change ifname to eth1.101


#3

Thanks! Working.
Now I got an IP number from the ISP.
(and other problems I have to work on later)

/etc/config/network:

config interface 'wan'
  option ifname 'eth1.101'
  option proto 'dhcp'