Instalace NextCloud - updater selhal při migraci PHP 7.0

Zdravím,
potřebuji poradit, co s následující chybou.

Oznámení o chybách

Updater selhal:
[string “transaction”]:311: [string “transaction”]:144: Collisions:
• /usr/bin/php-cgi: php5-cgi (existing-file), php7-cgi (new-file)
• /usr/bin/php-fcgi: php5-cgi (existing-file), php7-cgi (new-file)
• /etc/php.ini: php7 (new-file), php5 (existing-file)

Chyba vznikla při přidání balíku NextCloud do updater. Předpokládám, že se snaží zmigrovat PHP na verzi 7.0. Zkoušel jsem soubory přejmenovat, aby “nepřekážely”, ale ani to nepomohlo.

TurrisOS akutální - 3.8.3
Nedávno zmigrováno na btrfs.

Za případné nápady a rady předem děkuji. :slight_smile:

Soubory nejsou problém. Problém jsou zmíněné balíčky. Prosím zkontrolujte si co máte v /etc/updater/user.lua a /etc/updater/auto.lua. Pravděpodobně tam máte přímo balíček php5-cgi, nebo nějaký balíček terý na něm přímo závisí. Hodně informací je také možné získat příkazem grep php5-cgi /usr/lib/opkg/info/*.control.

Jen doporučím to, co tady na fóru už bylo několikrát zmíněno, teda nechat na routeru jen věci ohledně síťového provozu a vše ostatní (NextCloud, Pi-hole, atd) instalovat do LXC, většinou všechno funguje na první dobrou, nehledě na komfort při následné správě…

1 Like

Děkuji za radu. Nenapadlo mě se podívat do nastavení updateru. Po odebrání balíčku php5-cgi je problém vyřešen.

@vlk: V LXC jsem NextCloud měl a byl velmi nestabilní a pomalý. V LXC byl debian podle jednoho zdejšího návodu. Veškeré soubory byly umístěny na plotnovém disku, který byl připojený skrze sata řadič v miniPCIe.
Proto jsem chtěl vyzkoušet výkonnost v normálním prostředí.