Info: Small thing to do after adding mSata SSD

Just a note if somebody is adding mSata disk to omnia and finds them self wondering why one of the WiFi adapter is not working suddenly :wink: I know this might be common knowledge but hell, it was not mentioned in the video on CZ youtube…

Issue:
After adding mSata disk as per tutorial video:

  • Basic web setting shows 2 wifi interfaces but only the upper one is working ( 5Ghz )
  • 2.4 Ghz ( the one that was moved ) is shown but wifi is gone…

Solution:
jump into ssh ( putty ) log into your omnia IP ( 192.168.1.1 ? :smiley: ) with root as user and password.

Backup file: cp /etc/config/wireless /etc/config/wireless.old
Edit file: vim /etc/config/wireless
and remove block related to radio1, underneath is also radio2 just rename it to radio1 where it says radio2 ( two places )
Save, reboot and enjoy working configuration via web interface again :wink:

3 Likes

Thanks a lot for this info about this important “detail”, it will safe my time.

Hmm, I didn’t have to change anything, but that was probably because I installed the ssd before powering on the router for the first time, so the cards were detected at their new slots

Yes I think, if you did not turn it on before it should work automagically on its own :slight_smile:

Given that it is based upon OpenWRT, this might be a better option (once you’ve SSH’d in:

wifi down
wifi detect > /etc/config/wireless
wifi up

Of course, you would do this via wifi.

2 Likes

Hey there! I ran into the same issue and did some hand modifications to fix :slight_smile: Seems that this is a better solution.

Since the new radio2 block is completely unconfigured and your old radio1 block probably is fully configured, I’d edit the file in a different way:

The reason the radio1 block isn’t working, is simply due to the fact that the hardware has changed path. The auto-detected radio2 block, on the other hand does have the correct path to the hardware.

So my suggestion would simply be to move the path line from the radio2 block to the radio1 block.
(Or even simple, change the two values that differ.)
Following, I would delete the two blocks auto-generated blocks related to radio2.

In my case the important values looked like this:

config wifi-device ‘radio0’

option path ‘soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0’

config wifi-device ‘radio1’

option path ‘soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0’

config wifi-device ‘radio2’

option path ‘soc/soc:pcie-controller/pci0000:00/0000:00:03.0/0000:03:00.0’

And I would change it like this:

config wifi-device ‘radio0’

option path ‘soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0’

config wifi-device ‘radio1’

option path ‘soc/soc:pcie-controller/pci0000:00/0000:00:03.0/0000:03:00.0’

Following saving the file, I’d type reboot into the ssh shell, and enjoy that both my wifi interfaces are now working.

3 Likes