How to run simple static page on Turris, next to luci, reforis etc?

I was running several simple static webpages on Turris. Simply created folder in /www/ and put content there. I was then able to access that by adressess like http://omnia_ip/somefolder/.

However since TO 5.2 it is not working anymore, I am getting 404 Not Found. According lighttpd.conf document root is still /www/.

Any advice?

First shot from the side:

  • From external fix IP ?
  • any redirection from WaN to LAN?
  • http or https protokol ?

Local page, accessible from inside LAN. I used to have for example simple page where are generated graphs from vnstat or some static “index” pages.

In TOS older than 5.2 it worked perfectly:

  1. Created folder in /www/ (or symlink), for example that /www/vnstat/
  2. put some html files there
  3. access it from LAN as (or https, does not matter)

Since 5.2 it is not working anymore, I am getting 404, but content is there. For me it looks like behaviour of lightttpd has changed.

I was so desperate that I tried also webapps, but no success. In documentation is mentioned " List of available applications is read from directories /usr/share/turris-webapps/ and /etc/turris-webapps/.

I have only /usr/share/turris-webapps/.

I created there /usr/share/turris-webapps/11_somepage.conf with content


Created folder /www/somefolder/, put index.html there but same behaviour. I can see it on list of webapps, but then I got 404.

it is some stupid small thing I am overlooking:-)

OK, I got it. Looks like if webapps are installed they somehow hijacked document root.

So even if in /etc/lighttpd/lighttpd.conf is
server.document-root = “/www”

In fact is document root in /www/turris-webapps.

UPDATE: It is because of settings in /etc/lighttpd/conf.d/turris-root.conf

Any static content you put there is server perfectly.

Next to reForis, Foris and Luci ? This are WebApps no clasiccs web pages


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.