How do I update?

Hello, I just set up my omnia for the first time and ran ‘opkg update’ but I get these errors:

curl: (6) Couldn’t resolve host ‘’
Signature check failed.
Remove wrong Signature file.

Anyone know why this happen?

apparently the DNS → host resolution did not work. Check with nslookup

TOS provides pkgupdate for updating from the cli.

I tried some different things, but nothing seems to work. Internet connection seems to be fine though. I am connected with several devices and can ping websites. I will post output from the commands I tried:

Server: (null)
Address 1: ::1
Address 2: localhost

nslookup: can’t resolve ‘’: Non-recoverable error

line not found
line not found
line not found
unreachable: https:// curl: (6) Couldn’t resolve host ‘’

unreachable: https:// curl: (6) Couldn’t resolve host ‘’

uci: Entry not found
uci: Entry not found
Log: dnsmagic: libunbound: no data in answer
Challenge response error: Information about slot id couldn’t be obtained from DNS.
uci: Entry not found

from cli execute check_connection, just a basic/simple connectivity test.

I don’t have this command on my system, but the connection is ok. nslookup works for other websites. is the only thing giving me problems. Also, when I try to access from my browser it gives me security warning. Is it some problem with certificate? I don’t have knowledge about this stuff.

There is, least from the browser perspective, but that is secondary to the DNS issue the router is facing.

Maybe the DNS issue is just temporary, case of a negative cache entry - try with a reboot of the router, which should clear the DNS cache.

No, it’s normal that the certificate for this site isn’t “trusted by normal browsers”.


Based on this post,

I would suggest this time using re-flash, which is described in our documentation.