How Do I Access My Turris Omnia with SSH and Keys Rather than Passwords

yes, right, wonderful, concise hint, nice way to write a contribution, explains what to do, answers one question in a perfect way … I like your style!

probably will not help.
Because the reason for failure is probably not in doing ssh-copy the wrong way.

For debugging I strongly recommend to use the -v option:

ssh -v

It just told me things:

/home/username/.ssh/known_hosts2: No such file or directory
/etc/ssh/ssh_known_hosts: No such file or directory
/etc/ssh/ssh_known_hosts2: No such file or directory
get_agent_identities: ssh_get_authentication_socket: No such file or directory

What you expect? Just fix it!
I proactively deleted content in authorized_keys (in case of garbage).

After fixing these simple things it worked fine!

Setting PubkeyAuthentication in /etc/ssh/sshd_config did NOT have any effect on my system. However.

Turris OS is very sparse in providing things by default. Like
Turris Documentation is sparse in providing information.
This is an expert system:
No expert, no fun. Become an expert or go away.
However … you got options!
And eventually I learned something and it might work successful :slight_smile:

This topic was automatically closed after 60 days. New replies are no longer allowed.