Help upgrading to turris 4.0.3

Hi Turris Forums, I am struggling to upgrade my omnia to 4.0.3 I have copied the omnia-medkit-latest.tar.gz and copied it to a ext4 formatted flash drive and then did the 4 led boot.
With my laptop plugged into a lan port i am not getting an ip address and have no way of accessing the router. I have tried medkit from hbs and hbd, can i add that i have not found clear instruction on the forums or in the documentation as to the differences between hbs hbd. I followed instructions that said copy medkit.tar.gz to flash drive formatted to ext4 and press reset until 4 leds are on then release the reset button.
Can you one tell give me any help ? (i have a serial cable somewhere if i need, but i was hoping to use the flashdrive method)

hb? are explained in docs: https://docs.turris.cz/geek/testing/

Hi @beijjjj, I went thru this exercise last week and followed this article:
https://docs.turris.cz/hw/omnia/rescue_modes/#re-flash-router

The latest kit you will download will be 4.0.3, so you do not need to worry about the HBD/HBS stuff.

I have used FAT32 formatted USB key to perform the flash, but the ext4 used by you is supported as well.

UPDATE: Flashing the Omnia will take some time…

Thanks, I didn’t stumble across that! so i tried flashing medkit from hbs and now i have what appears to be a bricked router. power led on, pci2 led on , wan just flickering.
Ive tried roll back to last snapshot , same result, i’ve tried factory reset, same result.
Any ideas what i can try next?

I’ll try it again, I will test with a different flash drive just in case, I will report back as soon as I have tried, tomorrow most likely.

Take a deep breath. I too sometimes have difficulties because of the USB stick that I use, but in the end it succeeds. I too have an Omnia. Meanwhile, download the latest medikit from hbs (which is the stable firmware) and the relative verification file https://repo.turris.cz/hbs/medkit/omnia-medkit-latest.tar.gz and https://repo.turris.cz/hbs/medkit/omnia-medkit-latest.tar.gz.sha256, then you can move on to branch you prefer (hbk, hbl, hbd); for example I am now on hbk. If you propose to use the other branches for medikit (and not hbs), you get the result you tell me about and you cannot access the router.

  1. format the USB key in ext4, btrfs, fat32 or xfs (make sure through disk utility that the volume is clean, a logical volume a partition, otherwise it won’t work);
  2. copy both link files (version 4.0.3 hbs) to the flash drive and connect the flash drive to the Turris;
  3. hold down the reset button (behind the router) until LED number 2 starts to color (for a total of 4 LEDs lit);
  4. pay attention: the number of LEDs on must be four (neither 3 nor 5);
  5. wait for Omnia to restart; it will take a while and during the flash phase all the LEDs turn red; then it restarts again and all the flashes turn green and then turned on only wan, lan (if connected); for safety wait 3 minutes;
  6. with the computer connected via ethernet cable, try to access the address https://192.168.1.1.
  7. have fun!
1 Like

Success, so I tried with another USB stick , formatted on the same linux box to EXT4 and that too failed, so then I reformatted the original drive to FAT32 on my mac laptop and and tried again. This time it worked, I have access and TurrisOS 4.0.3 0a14e69 / LuCI branch (git-19.354.01383-590ecd6) running. I’m still not entirely clear as to the cause of the failed attempts but I’m thinking about the formatting that my linux box produced.
Many many thanks!

1 Like