Help - probably being an idiot!

Hi all

Got my Omnia yesterday and have a couple of questions.

Currently I have an Asus RT3200 as router and an AC68 (i think, it’s new) in AP mode. It all works perfectly but I wanted to upgrade the router for security reasons, hence the omnia. Router and AP are connected by ethernet, out of a lan port and into a lan port.

I have a BT supplied modem and 80gbit BT Infinity.

I switched the router for the omnia yesterday, and although I could get internet access if I switched off DNSSEC it was noticably slower browsing and using citrix. Also I could not get the AP to work. I could ping (omnia) but it was dropping out and there was no internet access. I assumed DHCP problem, and whenever I ran the check in Luci I recieved fails on 4or the tests. I assume the ISP config was ok as devices connected to the omnia worked ok (if a little slow). I treid the AP witha static IP (and the correct range settings on the omnia) and DHCP and had the same problem. I know nothing about openwrt so that’s probably the problem here but any advice would be most welcome. I assumed that not touching the AP, leaving as DHCP, would work out of the box!

Also, any advice on setting up a Huawei E3372 as a backup connection would be gratefully recieved - I followed the (excellent) guide for the setup of an internal 4g modem, but had no joy with the usb device, it just had RX/TX at 0 no matter what I did. This all works fine with the asus, but it’s an attackers honeypot!

Many thanks


For the dnssec problem have you tried to set a forwarding dns server to like (google public dns)? It is possible that your isp doesn’t have dnssec working correctly on its servers.

Disabling forwarding also often helps (for me it’s the preferred mode anyway).