Google dns over pppoe

Hey Guys,

I’ve had problems with dns forwarding, if its on, not all web pages resolve. If i turn it off, it all starts working. I’ve read that it could be an issue with my isp dns servers.

I have an ADSL bridge, so am using pppoe, but when I select pppoe the option to specify dns server disappears! Can I set that in Foris, or do I need to dig around and try to set that in the dsl bridge?