FRITZ!Powerline web interface can't be reached

Hey!

I hope this is the correct category, please move my topic otherwise.

Finally I am a happy owner of a Turris Omnia and started to set it up already. I just used the guide through Foris, installed all updates, installed LXC and created a container and installed Pi-hole.

Every DNS request goes through Pi-hole, either on my phone, which I connected through Wi-Fi or my laptop, which is connected through ethernet.

But, I have more devices I want to connect through ethernet in another room with a FRITZ!Powerline 1220E set. This setup has worked before everytime on my old modem which I got from my ISP.

In the guide it says that I am able to connect to the web interface of the powerline adapter through hxxp://fritz.powerline, which doesn’t go anywhere, hxxp://fritz.box also doesn’t go anywhere. I also am not able to connect to the web interface by going to hxxp://192.168.1.X directly, where X is one or the other adapter.

I changed http to hxxp, because I can only add 2 links.

When I run an nmap scan on, only port 7547/tcp is open, where I’m wondering, shouldn’t there be an open port for a webserver, if there should be a web interface I should be able to connect to?

Manual: https://assets.avm.de/files/docs/fritzpowerline/FRITZ!Powerline%201220E/FRITZ!Powerline%201220E_qig_en_GB.pdf

The manual in english is only for one specific adapter, not the set. The german manual is what I used. See https://assets.avm.de/files/docs/fritzpowerline/fritzpowerline-1220e-set/fritzpowerline-1220e-set_man_de_DE.pdf

There is also a FRITZ!Powerline software which I installed, which also doesn’t detect the Powerline adapters.

Additionally, I can pair both adapter physically and if I connect to the other one with an ethernet cable, I get my internet connection and am also able to connect to reForis.

Does anyone have any idea what I could try out next? Or am I making the problem myself through using Pi-hole or any other setting I did?

Thank you!

Versions/Settings:

reForis version: 1.1.2
Turris OS version: 5.3.1
Kernel version: 4.14.254

My DNS settings in reForis are:

  • Use forwarding → Quad9 Filtered (TLS)
  • Enable DNSSEC

In LuCI, I changed the following settings:

  • Network - Interfaces - LAN - DHCP Server - Advanced Settings - DHCP-Options: 6,192.168.1.X
  • Network - Interfaces - WAN - Advanced Settings
    • unchecked Use DNS servers advertised by peer
    • Use custom DNS servers: 192.168.1.X

X is in both cases Pi-hole.

With Pi-hole I use Quad9 (filtered, DNSSEC).

This isn’t really relevant except for the router itself, as you set up DNS path Pi-hole → Quad9 directly, for all your clients. Consequently I believe that you don’t validate DNS(SEC) locally, for example.

Well, I’m picking on stuff that seem not related to your problem… as the powerline UI didn’t work even when you entered IP address directly.