Feedback about experimental migration to 5.1.4

Just to let you know that I switched from 3.11.21 to 5.1.4 some days ago and it just worked. After enabling migration packages and approving updates, the migration did not start automatically for some reason, not even after more than 5 minutes. So I researched that the migration hooks into the Update with a lua script and just ran pkgupdate in a GNU screen session. That did the trick.

I had OpenSSH installed and use git to version various files in /etc. It all works. I had to migrate WLAN settings in Luci, but other than that, it just works as before. I was still able to log in using my SSH key and the git repo was still there. It is so nice that this update worked like in Debian by upgrading packages and not replacing the complete image. I did not yet review all of the known issues on the migration documentation page yet, I bet I will read through it at some point.

I do have two issue with reForis 0.9.4 though:

  1. It reloads the notification page every few seconds. This is very annoying when I browse through another page to review and/or change some settings. I looked everywhere whether I could change the timeout.

  2. On https://ROUTER/reforis/network-settings/wifi I either receive a timeout or an unknown API error.

I can report both issues on Gitlab of course. But I bet this two issues may already be known, so for starters I just mention it here.

Thanks for the marvelous work on TurrisOS 5. I expected all kinds of trouble, but it just worked out smoothly. Now I can look into what kind of VoIP software is available for the new OS and work out a solution that I could migrate to another provider which uses VoIP, without having to use their Fritzbox with proprietary firmware.

Have a happy, peaceful, healthy and abundant new year, everyone!

1 Like

Hi and happy new year! :slight_smile:

I too did upgrade my TOS from 3 to 5.1.4. It was flawless for the networking part, but I’m using also Nextcloud, Samba and OpenVPN and each service had some minor or bigger issue.

OpenVPN - Was simplest, I just installed it from packages selection in ReForis and it worked. It added some tr_vpn_cl zone and rule in firewall, but it kept my original vpn zone and rules too. I guess this new setting is some kind of default/example and can be removed? Its not assigned to any interface.

Samba / NAS - For some reason it didn’t automatically mount my HDD connected over the USB. I had to install packages for NAS and Samba in ReForis. After restart it mounted the HDD as expected. But there is inconsistency between Luci and Foris. Luci correctly shows mounted HDD. Foris shows HDD as present, but not mounted (not checked). Since confirmation button says also “format the drive”, I’m really not interested in trying it to get it in-sync. There is no “Storage” panel in ReForis yet, so I can’t tell if it would show drive as mounted or not.
As for the Samba part, my config (actually modified template) for Samba 3 was kept and worked with no changes (I just set min protocol to SMB3), but all configured “shared folders” were missing (in Luci), so I had to re-add them.

Nextcloud - Was the biggest problem. First to know, I didn’t check it in packages in ReForis, since it all seemed ready just for running occ upgrade to finish the upgrade to version 18. I’m not sure what that would do. Also I didn’t perform update of the calendar and some other plugins before upgrading TOS, since I expected full update of nextcloud to take care of it. I’m not sure, if it caused the later issue.
I wanted to perform yet another backup of Nextcloud, using mysqldump, but command was not present. I had to manually install mariadb-client-extra package.

Then occ upgrade failed with:

An exception occurred while executing 'SELECT `o`.`id` FROM `oc_flow_operations` `o` LEFT JOIN `oc_flow_operations_scope` `s` ON `o`.`id` = `s`.`operation_id` WHERE `s`.`operation_id` IS NULL':\n\nSQLSTATE[42S02]: Base table or view not found: 1146 Table 'nextcloud.oc_flow_operations_scope' doesn't exist  ("version":"")

I’m really not sure why, since Nextcloud was updated from the package and I checked and resolved all warnings/tips in admin overview (except plugin update) before updating the router, but it seems to be known bug and can be solved by running SQL

ALTER TABLE oc_flow_operations ADD entity varchar(256) DEFAULT NULL;


occ db:add-missing-columns
occ db:add-missing-indices

But I missed these simple solutions :frowning: and went with replacing current install with the same version from Nextcloud website. So I unpacked it, fixed files ownership/permissions and replaced config.php and data/ with my backup. Then occ upgrade worked…hooray…and not so fast.
Upgrade removed calendar and contacts, but failed to find the newer version, so I ended up without them. Also I can’t see any “available” apps in the nextcloud now.
This seems to be also a known bug since libcurl in OpenWrt is not compiled with libz or zlib (or whatever the name is). So I installed calendar and contacts manually and it works now. But this bug affects also newer versions of nextcloud.
There seems to be also another thread on this forum about the same issue, so who knows what is the real cause and if it will be fixed by next nextcloud bugfix update.

Other - I noticed weird issue with updater. I did set automatic updates in ReForis right after the upgrade. Later that day it installed a bunch of kmod like packages and then it did the same 3 times in the last 2 days (always same set of packages, like it was not remembered). Also first run removed my manually installed mariadb-client-extra package, but it didn’t happened in later runs.
So I went to the old Foris, disabled automatic updates there (it was reflected in ReForis) and then re-enable them again in ReForis. It didn’t try to install those packages again for the day, so I hope its OK.

I know, that documentation states, that some services are not-reenabled after upgrade or might not be present, but it would be nice, if I had checked “NAS” if Foris (v3) to have it checked and installed also in ReForis (v5). It make sense to have an external HDD connected and mounted as expected since other services like nextcloud might rely on its content. Same goes for OpenVPN. Not sure, if “Samba” was separate option in v3. Also I’m not sure, what would enabling “Nextcloud” package did to my current (or after upgrade) installation since it was already upgraded/installed, just probably not reflected by ReForis.

Overall upgrade was mostly success, since I was able to fix it. I also bought NAS box for my Omnia and put the HDD inside and connected it over SATA, so watching videos no longer hiccups. Seems that USB was the real bottleneck.

Keep up good work! :slight_smile:

1 Like

I just tried the experimental migration to 5.1.5, and it worked better than I expected. No need to launch it manually. I did need to reboot manually, though. After installing 5.1.5, the router was in this weird half-5 state and the reboot command wouldn’t do anything. I needed to reboot -f.

I was pleasantly surprised that the switch config was migrated to DSA. The kmod for the USB Ethernet interface was also installed automatically.

I was unpleasantly surprised that DSA doesn’t seem to have an obvious way to see the physical port status in Foris nor LuCI, only reForis.

A few adjustments were necessary. Auto-update and DNS over TLS forwarding needed to be turned back on. The script I use for the AT&T router bypass needed to be updated to be compatible with Python 3, and its invocation in rc.local adjusted for the new WAN interface. Other than that, it has been pretty smooth so far.