Errors when restarting resolver

Hi,

when I do /etc/init.d/resolver restart output is:

/etc/init.d/resolver restart
Called /etc/init.d/kresd stop
/etc/rc.common: eval: line 1: get_dnsmasq_dhcp_script: not found
Called /etc/init.d/kresd start
uci: Entry not found
__call_kresd hints.config('/tmp/dhcp.empty')
ret > 
__call_kresd hints.add_hosts('/tmp/kresd/hints.tmp')
ret > 
__call_kresd hints.add_hosts('/tmp/dhcp.leases.dynamic')
ret > 
Refresh kresd leases
Called /etc/resolver/dhcp_host_domain_ng.py

It looks like everythink works, even local DNS resolution after 3.8 update, but I would like to ask if it’s expected behaviour?

same problem here, but dns does not work at all… basically there is no dns server running on my omnia

I had the same error. I fixed it by checking in Foris → DNS → “Disable DNSSEC”.

That’s really strange. That script has no connection to DNSSEC. EDIT: well, except for the fact that it’s used to define hints and those are never validated, but that’s more of an anti-connection.

I do have the very same error - but my DNS resolving works without any problems.
@vcunat do you know what this error means? My DNSSEC is still enabled.

The error will most likely get fixed in 3.8.1. https://gitlab.labs.nic.cz/turris/turris-os-packages/commit/3fe948c7a1c95

Ok, that sounds good. Thanks.