Error "bad rx status 0f850000" when routing

I’ve an issue:

  • When I download a 3MB file from my Omnia, it is OK.
  • When I download the same file from my computer, it fails. I get lots of errors in /var/log/messages:
    err kernel[]: [45073.592721] mvneta f1034000.ethernet eth1: bad rx status 0f850000 (max frame length error), size=1504

DSL box port is 1000Mbps
Cables are cat6
MTU is set to 1452

Tests:

  • Pings are OK
  • I tried to downgrade Ethernet between the DSL box and the Omnia in 100Mbps half-duplex (ethtool on Omnia): no change
  • When I connect a computer directly on the DSL box, there is no problem.
  • I tried to insert a 100Mbps switch between the DSL box and the Omnia: no change (When I connect a computer on the same 100Mbps switch, the computer reports no error)

Try “ping -s 1440 …” and “ping -s 1500 …”.

That’s it!
I’ve tested that from the Omnia, but not from my computer.
Setting mtu on my computer resolves my issue.
Thanks a lot!

What MTU is true ? Router and all statition must have equall size MTU … isn’t it the truth ?

I remove all mtu statements from /etc/config/network, and then set down and set up wan interface:

# ip l set down dev eth1
# ip l set up dev eth1
# ip a l dev eth1
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1452 qdisc mq state UP group default qlen 532
link/ether d8:58:d7:00:30:ca brd ff:ff:ff:ff:ff:ff
inet 192.168.3.158/24 brd 192.168.3.255 scope global eth1
   valid_lft forever preferred_lft forever
inet6 2a01:e34:eebf:b5d0::2/126 scope global 
   valid_lft forever preferred_lft forever
inet6 fe80::da58:d7ff:fe00:30ca/64 scope link 
   valid_lft forever preferred_lft forever

Correct mtu seems to be 1452.
=> I will set it on the lan interfaces, and advertise it with dnsmasq.