DNS returned by DHCP

Basic question (which I’m too slow to work out this morning). How can I set the DNS server supplied by DHCP (dnsmasq)? I don’t mean how to set the DNS that Knot forwards DNS requests to, but I mean change the DNS server supplied by DHCP so that clients don’t use Knot at all.

Thanks. BTW, regarding various DNS problems I and others are recently having, there seems to be some real problem here. What I did:

  • Went back to HBT
  • disabled IPv6 in WAN
  • set DHCP so it doesn’t provide IPv6 addresses
  • set Knot to resolve, not forward.

DNS is still flaky and not working great. Next options for me are to give up on Knot and use external DNS on all clients. And factory reset Omnia (which I’m planning to do anyway) :wink:

By “flaky” you mean slower, I assume.

Improved non-IPv6 in non-forwarding mode isn’t in HBT yet, so I suspect in your case you’d still benefit from setting net_ipv6 explicitly. (There is some auto-detection in init script, firing two minutes after (re)start of DNS, but I suspect it’s not perfectly reliable.)

Flaky = slower and unreliable (need to hit browser refresh frequently)

EDIT: Just set net_ipv6 to 0. Let’s see if that helps.

1 Like

Setting net_ipv6 to 0 seemed to solve all my DNS problems. Hurray!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.