Different (lan x guest) speed wifi - reason?

Hello, everybody. I run Turris Omnia TOS 3.11.14. Wifi i run for a long time 5Ghz and in the 2.4 main network and Guest. The only peculiarity is to set the reduced broadcast power of all wifi. Environment 2.4 is severely disturbed. I just practiced speedtest from the Samsung Tab S2 when I gradually connect it to individual networks and i got the following results:

2m from router - (second room)

5 Ghz … 20/20 - (16/20)
2.4 lan … 10/16 - (15/15)
2.4 guest … 60/80 - (22/23)

Edit : Sony Xperia Z3 Compact … 2m from the router
5 Ghz … 23/30
2.4 lan … 16/27
2.4 guest … 40/42

Guest results near the router change significantly even when a small changed position … like 40/60, but it’s still 2x faster.

I have installed Pakon and AdBlock, QoS is not installed. Uninstalling Pakon with subsequent restart has no effect on the results.

I can not explain the great results 2,4 guest against wifi-lan … same channel, same encryption, same broadcast performance.

I had the same experience with low wifi speeds.

resolving the issue involved in my case:

  • remove/rename /etc/config/wireless via ssh
  • reset wireless settings in foris
  • don’t touch the configuration in luci, that broke my connection ever single time

It’s a very weird issue.
I since upgraded to Turris OS 4.x and the developer release 5.x. Didn’t try to reproduce the issue so far, but if it breaks again, I will report.

Hope it’s helpful.

Foris does not have “country code” , meanwhile Luci does and needs to be set. If left empty and you save+apply the uci config from Luci interface, it might not work properly (or at all).

I think it is better to set the wifi in Luci (and look into “Advanced Options” tab … where is the country-code and some other params you can play with to tune it up, distance, signal level… Foris should handle wireless config saved by Luci. (i do not use Foris unless it is necessary or just for some essential features missing in luci)

Similar issue where Foris and Luci do the changes in UCI configs regardless the other related option “dynamic/static domains” and “port 0 vs port 53” (for resolver/kresd/dnsmasq) it took me a while to found that glitch.

from what i found out, foris sets the country code depending on the localisation configuration.

it didnt’t work for me to set the country code in luci. also luci didn’t recognise the right maximum allowed transmitter power in 5ghz wifi and set it to maximum 79mW.

i guess there was something wrong in the luci country code configuration, too…