DHCPv6 Static lease

Hi, Im setting up a DMZ IPv6 net on my router. I’m trying to get the router to hand out address by static leas but it looks like it wont obey.

Under DHCP in the Luci interface im adding.

Hostname: test
DUID: 0002012233…
IPv6-Suffix: ::2bad

Anything im missing or set wrong? Im on Omnia Turris OS 4

If client uses SLAAC it will be configuring its IPv6 address(es) from the prefix handed from the router.

IPv6 leases can queried from router ssh cli with ubus call dhcp ipv6leases

I’m running statless + statefull in the config on DHCPv6. The prefix and sub net and stuff works perfectly. It’s the address thats handed out and set by DHCP that do not respect the suffix i set in the static lease list. It looks to be ignoring it and just giving it a new one. Setting an address manual on the machine work


This was not clear from your initial post.


Reached EoL as of today since 5.0 been released, which you might try. I cannot reproduce the issue on my node, with settings:

it turns out as expected

1 Like

Will wait for the update to 5.0 i think. Will also try to remove the leading :: on my sufix and set a leas time. Could also be that there is a bug sins there is no ipv4 on that net. So the Mac and ipv4 field is blank

Thanks i got it. Removed the leading :: on the suffix and added a lease time. Looks like the UI do not validate properly and was hard to find a good example. The screenshots helped allot thanks :slight_smile:

1 Like