Delay when visiting new websites

Ever since I got my omnia I noticed that visiting new websites has a two second delay. I’m guessing this has to do with DNSSEC. Is there any way to turn it off?

Are you using Chrome?

Hi,

Not to steal OP’s thread but I’m (still) suffering from the very same problem.
My previous router was an Asus RTN66U which displays websites instantly. No matter if the website was visited a few seconds ago or never.
After I got the TO newly visited websites open after 3-5 sec. (displaying resolving www…). Subsequent visits open the websites quickly (< 1 sec.). Visits after a few hours open the websites again slowly. I reported this issue in a separate thread which give me some hints but no resolution.

What i did so far is disabling dnssec and forwarding. This gave a little bit of improvement. Also the update to TO 3.3 seemed to improve the situation a little bit.
Further i followed the advice to disable knot in favor of dns-masq. This rendered myTO completely unusable. As I’m no expert in these things i guess a mistake was made somewhere. A step-by-step guide to do this (for Luci) would be appreciated.

TIA,

Jack

I am not sure if you guys already have done this…

open /etc/config/network under “lan”, put these

    list dns '8.8.8.8'
    list dns '8.8.4.4'

So it will look like this…

config interface 'lan'
        option ifname 'eth0 eth2'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

My WAN situation isn’t like many others, but i also have put those list dns under the wan interface i am using. After that i haven’t had no problems with the delay YET.

I’ve solved the problem a few weeks ago by enabling DNS forwarding (I use DNS Watch).

I confirm an effect (enabling DNSSEC forwarding ) on speed up loading pages.

The same symptoms … thank you

OK, what did the trick was the advice from amq.
I tried his/her advice before but rendered the TO unusable. After the 3.3 update this seems to work now.

Had the same problem… Solved by replacing kresd with dnsmasq:

System - Startup - disable kresd and resolver; enable dnsmasq
in /etc/config/dhcp change option port '0' to option port '53'
Reboot

Thanks.

In the other post you said you tried to use 8.8.8.8 as dns servers and it didn’t help. Did you set them in Network-Interfaces-WAN, in the LuCI?

Hi Darknet,

I did what is described at the end of this post [SOLVED] Slow DNS resolution (no forwarding) when WAN is not active.

And yes, I set it in Network-Interfaces-WAN with Luci.

Thinking about it, it doesn’t make much sense to do this in my situation. My old Asus router worked just fine with the DNS servers of my ISP. So why would TO not work with them (or only slower).

This leaves of course the question why disabling knot/resolver in favor for dnsmasq makes such an performance improvement?

I’m guessing here, but was the “Use forwarding” option enabled when you put in the google dns in the interface? Maybe there was some incompatibility between your provider DNS and Knot, but I’m running my omnia using google dns and it’s pretty snappy.

I tried it with “Use forwarding” on and off. It made no real difference.

I think there are at least some issues with knot. It would explain my (and others) website opening speed problem.

You have to set alternative DNS servers for your WAN interface in LuCI or UCI and disable peering, then enable DNS forwarding in Foris. This helped me.