Data collection isn't collecting data

I re-flashed my router with 3.10 last week, and data collection is no longer working.

  • Data collection is enabled in the “data collection” tab.
  • The “about” tab says “Sending of uCollect data: :x:Offline (status updated 286141 seconds ago)”
  • The “your router” tab in says “We haven’t received any data from your router yet. Please make sure that the data collection is enabled on the “Data collection” tab of the web interface of your router.”
  • The “your router” tab also said “Data sending outages 48 h”.

I tried disabling data collection, unregistering my router on, and deleting my device on Then I waited 48 hours, re-enabled data collection, waited 48 hours, and re-registered my router. Data collection is on, my router is re-registered, but it’s not sending data.

The same issue on my Turris Omnia. uCollect is offline since Sunday when I installed 3.10 from USB. Neither reset nor unsubscribe/subscribe to data collection from Foris helped. Firewall log sending is online.

Worth mentioning that I’ve also tried fixing it by making /etc/crontabs, but that directory was already present. So it’s not that problem.

Same problem here, reinstalled Omnia on Sunday… I have also opened ticket to support…

Can you see “/usr/sbin/collectd” in “Processes” http://<omnia_address>/cgi-bin/luci/admin/status/processes?
If you can access your Omnia using SSH, you can try to restart “collectd” process:
/etc/init.d/collectd stop
/etc/init.d/collectd start

Yes, process is running, but from what i have seen, the problem might be in missing ssl certificate (ucollect-server.pem) which should be in /etc/ssl… i don`t have it there… not sure how to generate it, or if should be present in certificate package (not sure the exact name, but when listing the content of that package this one is not there…)…
Still waiting for response from support team…

Hello guys,

We’re aware that uCollect for some users doesn’t work. We’re working on it and bring the fix for you in Turris OS 3.10.2., but if know what are you doing you can install this package for
Turris 1.x
Turris Omnia.

Otherwise, please be patient and wait for 3.10.2.

Btw: @trubkyn thanks for reporting the missing ssl certificate. :wink:

1 Like

no problem, thanks a lot for quick fix! :wink:

On 3.10.2 but still “offline”

“Sending of uCollect data Offline”

I’m having the same problem ucollect isn’t collecting data and remains offline. Like the others in this thread I started with the “re-flash router from flash drive” procedure with the latest medkit v 3.10.2. I setup my omnia manually, I did not restore any configuration files in case that was an issue.

socat is throwing an error “OPENSSL” error. I wonder if my omnia is missing an SSL cert.

2018-06-20 19:42:37 info ucollect[4564]: Reconnecting to now
2018-06-20 19:42:37 info ucollect[4564]: Socat started
2018-06-20 19:42:37 err ucollect[4564]: Error from socat: 2018/06/20 19:42:37 socat[4658] E unknown device/address "OPENSSL"
2018-06-20 19:42:37 warning ucollect[4564]: Remote closed the uplink, reconnecting
2018-06-20 19:42:37 warning ucollect[4564]: epoll_wait on 4 interrupted, retry

My firewall is sending data but ucollect refuses to collect.

Does anyone have any suggestions on correcting this problem?

I have the very same problem as John_Irvin, with Turris 1.0 after updating to 3.10.2 (err ucollect[836]: Error from socat: 2018/06/22 12:58:27 socat[884] E unknown device/address "OPENSSL").
Sending of uCollect data is Offline.
(Sending of firewall logs is Online.)

Please advise.

No new info here, just wanted to report I’m also having the same issue as everyone else on TO w/ 3.10.2:

http:// <omnia_address>/foris/config/main/about/

  • Sending of uCollect data Offline (status updated 2 seconds ago)
  • Sending of firewall logs Online (status updated 141 seconds ago)

  • We haven’t received any data from your router yet.

Excerpt from /var/log/messages:

2018-06-22 11:14:20 info ucollect[23899]: Socat started
2018-06-22 11:14:20 err ucollect[23899]: Error from socat: 2018/06/22 11:14:20 socat[23909] E unknown device/address "OPENSSL"

for me I’m getting something a bit different. I get “Sending of uCollect data online” in Foris but the graphs at show much less usage than there should be (only 400kb per day of throughput)? I am on 3.10.2 as well.

It looks like this bug is not fixed. sent note to tech support.

@Pepe anything I can try here? as noted myself and several others are still having problems with this in 3.10.2 and it’s not clear what to try next.

please, can you try to install this package for Turris Omnia and this for Turris 1.x and see if it is better?

I too am having the same issue with Socat. I will have access to the router next week and install the package you mention. I’ll let you know if it resolves the issue.

I can confirm that the new version of Socat solved the issue for me.

I can confirm that socat_1.7.3.2-3_mvebu.ipk restored my service, I’m now sending ucollect logs. Thanks.

the new socat looks good so far, will keep an eye on it.

Guys thank you for your testing. We have included it in Turris OS 3.10.3, which we released at morning.

1 Like