Connection failed in Foris (unsolved) and issue (solved)


I have problem with loading of site - its czech version works fine. Through mobile data, the site works fine.

ping: bad address ‘’

traceroute: bad address ‘’

nslookup: can’t resolve ‘(null)’: Name does not resolve

nslookup: can’t resolve ‘’: Name does not resolve

Connection test:

Everything other works fine, where is the problem? :confused:

Really? :joy:
Your screenshot says so?

Well, except connection test…

The connection test would suggest that network access from the router itself is severely broken. For start, I would try direct IP from the router, e.g. ping and if that works, try a few domains from the router, say nslookup

Ping to works, all other sites I have visited works, but only this one does not. Very strange. Will try today on evening, after 3.9.1 update if it helped or not…

Well, updated and the result is the same:

nslookup: can’t resolve ‘(null)’: Name does not resolve

Address 1:
Address 2: 2001:1488:0:3::2

Well after no answers here, I got back to snapshot from 3.12.2017, where the site finally works. Connection test had erros only on IPv4 gateway connectivity and IPv6 connectivity. Then I have update to latest version and it seems, that site works, but connection test gives errors on all test types…

Should I reset the router to factory defaults or what? It is very strange.

Updating posts doesn’t make threads shown as updated (doesn’t send notifications, etc.).

It is strange. If you run the check_connection over ssh, it’s more verbose, and I wonder what it prints in your case.

So, I made complete factory reset from USB, and the result is that site works, but connection test has only errors.

Internet connection work normally.

How to run connection test via SSH? When I try it, it returns: -ash: connection_test: not found

Edit: At least, I have found problem of site. Adblock with Easylist EasyList Czech and Slovak - it is blocking it, but it is strange, that previously, before update to OS 3.9 it worked, and after 3.9.1 update, there was no Adblock installed.

1 Like

I’m sorry, the name is check_connection. The removal is probably explained by Adblock not creating/updating adb_list.overall (Omnia with adblock1.3.3-1)

Well the result is:
root@turris:~# check_connection
Pinging … FAILED
IPv4 Gateway: FAILED
IPv6 Gateway: FAILED

Apparently the IPv4 Gateway is wrong and you should change it. It probably doesn’t work – well it might be filtering pings from your LAN, but that would mainly create confusion…

But why? Every of WAN, LAN, DHCP settings are on “auto” and all these problems started after OS 3.9 update. I thought it was due to som bad update, but this is happening on fresh OS 3.9.1 installation…

“auto” means it will use DHCP to find out, i.e. it just delegates the choice to others. I can’t say I have a good understanding of DHCP, unfortunately.

So, maybe I have to write nother thread,or right to the developers…

do you use encrypted connection (HTTPS) for accesing administration interface?

I don´t know exactly, but I use default option, so maybe only http (not at home to check now).

i had the same problem on my omnia. exactly the same.

With connection test or site loading?

2 Pepe: Because of this questions new thread…

No, you created duplicated thread with the same issue. This thread doesn’t have many posts and you have here 10 posts. No one else that you had problems with You could edit one of your latest post to be more clear. //EDIT: Also you (or somebody else) could change the name of this thread. I did that and it should be better. :wink: You won’t get respond faster if you create duplicated posts or threads.

So back to your issue, when Connection test failed in Foris. (When is stuck on loading that’s a problem with https and it’s included in our Errata.)
As @vcunat pointed right command check_connection doesn’t work in CLI for you.
From IP of your gateway, I could see that you have as ISP Orange Slovakia is that right?

Send us diagnostics to our support by email don’t post them here or don’t upload them to some file hosting.

Yes, I had problem with that site and that was in the name of the thread, so logically (at least for me) was to create new thread with connection problem as it is more interesting for other, who don´t know about that site…
But you are here the boss and I am accepting it .

To current issue: You are right, my ISP is Orange Slovakia. Will send diagnostics soon.

Edit 16:57: Diagnostics sent.