CIFS suddenly agonizingly slow

Howdy folks. I’ve got an issue that’s persisted over the past several days, and I’ve finally tracked it down to my Omnia. It looks like something has screwed up the performance of my network shares. I have the NAS perk, so I have two drives shared over CIFS (I had tried NFS, and it was actually slower somehow.) Everything has worked fine for a year or so, but in the past week, my networks shares will slow to a crawl, and then crap out. With my Windows PC, I have no problem listing the disks contents, but trying to transfer a file will be super slow (.40 MB/s), and the operation will eventually stall with an unexpected network error.

One of my linux machines acts similarly to Windows (can list contents, but slow transfer). My primary linux server can’t even list the contents.

How would I begin to troubleshoot this?


1 Like

Update on this, rollback to pre-6/27 update fixed this.

Same here. Speed is good right after reboot, but gets worse and worse. Same with CIFS and NFS, Windows and Linux clients.

Well, be careful. After rolling back, and disabling updates, my Omnia lost internet connection around noon the next day. Restarting ended up in a bootloop (with the front leds endlessly Knight Ridering it back and forth). A rollback reset didn’t work, so I ended up having to use a medkit to reflash my router. I pulled the disks from the NAS, and am not using that anymore.

Switching sata drives io scheduler to “noop” makes it barely usable, still slow as hell and minor hangs, but no long hangs anymore.

Why there is no “cfq” scheduler available?

Edit: I too moved disk jobs to a different machine. Next phase move to OpenWRT.