Can't turn off LED's after 6.01 update

Hi. I’ve placed my Turris Router in a place where it’s convenient to have the LED’s turned off. Now after the 6.01 update it seems that I cannot do that any more. I’ve tried choosing colour Black and state on, but nothing happens! Maybe there’s a new way that I should think and choose colour?

I would like help to be able to turn off the LED’s again, Thanks :slight_smile:

For now, the only way is to use the hardware button at the front panel.

Reboot still resets the LED status for me, so I now have to use the button after each reboot. (I hope this will get fixed soon-ish.) EDIT: it was particularly annoying due to the habit of doing auto-reboot during night and resetting brightness to max.

My router’s in my bedroom, and I know EXACTLY when it’s been rebooted since 6.0! :sweat_smile:

4 Likes

As a workaround you can put a command in rc.local like
rainbow brightness 0
or
echo 0 > /sys/class/leds/rgb:power/device/brightness

Same issue for me on my Turris 1.1:

root@turris:~# rainbow brightness 0
Command failed: Not found
Command failed: Not found

On Omnia that’s the same with command failed lines but it work.

1 Like

you also need to set the LED in http://192.168.1.1/cgi-bin/luci/admin/system/leds as I described here Podivné chování utility rainbow po upgradu na TOS 6.0.1 - #3 by xsys

Is it possible to get a translation of the post you point at?

Maybe it’s to simple but can’t we just have an on/off option?

I’ve noticed that rainbow has been updated twice in a short time. But I do not see any change in behaviour.

:smiley:

see

1 Like

These are the kind of stupid bugs that convince me that nobody at CZ.NIC actually uses these devices.

1 Like