Can't login to SSH

I’ve set my Luci UI root password and it works in the browser but when I try to login from my Fedora client I get this error and never any password prompt.

https://bpaste.net/show/a47ba47439d0

That’s kind of odd, it looks like your client isn’t allowing password and keyboard-interactive, it just gives up after publickey fails. What client are you using?

Try just using ssh root@<ipaddressofomnia> from a plain terminal and see if that works.

Do you have a ~/.ssh/config file with some funny options in it?

Ah yes you’re right, I had a workaround in my local ssh_config for a bug in Fedora 25 that had worked for my other hosts but wasn’t working for the turris.

PreferredAuthentications=gssapi-keyex,hostbased,publickey

Managed to figure it out by using ssh -F /dev/null root@<turris ip> and then I got the password prompt.