Can't connect to ISP via ONT device

Just upgraded to my 40Mb VDSL+ service from CenturyLink to gigbit fiber. Unfortunately, I’m having difficultly getting my Omnia to establish a WAN connection with the ONT.

I had a VDSL+ connection to CenturyLink, using PPPoE. It used a Actiontec C1000A VDSL modem set in bridging mode. This worked reasonably well (no problems with the Omnia).

The technician installed a Calix 716GE-I ONT and ZyXEL C1000Z modem/router combination–the combination connects to the internet as expected. The LAN port 1 of the ONT is connected to the WAN port of the ZyXEL router. The router is set to PPPoE:

I’m using a similar configuration for the WAN:

General

Advanced

Physical

The relevant part of dmesg after I connected the ONT’s LAN 1 port to the WAN port of the Omnia:

[   57.361990] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   63.361058] mvneta f1034000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
[   63.361078] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[   88.682098] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   94.681083] mvneta f1034000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
[   94.681108] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready

In Foris:

** edit 0 **
The contents of /etc/config/network:

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd22:91e8:0e0f::/48’

config interface ‘lan’
option ifname ‘eth0 eth2’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ‘60’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0 1 2 3 5’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘4 6’

config interface ‘torguard_vpn’
option proto ‘none’
option ifname ‘tun0’

config interface ‘wan’
option proto ‘pppoe’
option username ‘username@qwest.net’
option password ‘password’
option ipv6 ‘1’
option ifname ‘eth1’
option mtu ‘1492’

config interface ‘wan6’
option ifname ‘@wan
option proto ‘none’

Questions:

  • CenturyLink doesn’t offer IPv6. Is it safe for me to remove the wan6 interface and set ipv6 to 0?
  • Apparently, I need a VLAN entry that is ‘tagged’ 201. How do I do this?

** edit 1 **

I set the ZyXEL in ‘transparent routing’ mode and I’m able to connect the Omnia to the network. The ZyXEL’s WAN:

I’d really like to remove the ZyXEL dependeny from my network.

What sort of changes to I need to make to get this to work?

Solved in this thread: https://forum.test.turris.cz/t/difficultly-assigning-vlan-to-wan-correctly/3899